aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-20 23:17:44 +0800
committertrevor <trevor@FreeBSD.org>2003-11-20 23:17:44 +0800
commit1035b3c9830c837a398f1e67eb928b4a5bef7551 (patch)
treea0bd106874c751bb8e068d081b6eeb255fedbf08 /x11-wm
parent577fc09ea984d8db5d6d652ec544c8505e103262 (diff)
downloadfreebsd-ports-gnome-1035b3c9830c837a398f1e67eb928b4a5bef7551.tar.gz
freebsd-ports-gnome-1035b3c9830c837a398f1e67eb928b4a5bef7551.tar.zst
freebsd-ports-gnome-1035b3c9830c837a398f1e67eb928b4a5bef7551.zip
Attempt to create and delete share/gnome/wm-properties/.
Submitted by: Darren "igla" of batterybackups.net (also noticed by Andreas Semborg) Install header files where they can be found during compilation of obconf. This fixes the problem addressed by Tim Bishop in PR 58836, but in a different way.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 5cdf303ba1b5..b32a39928717 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -66,8 +66,8 @@ pre-install:
.for ii in openbox/xdg/openbox openbox/xdg openbox
${ECHO_CMD} @dirrm etc/${ii} >> ${PLIST}
.endfor
-.for ii in openbox/3.0 3.0
- ${ECHO_CMD} @dirrm include/${ii} >> ${PLIST}
+.for ii in include/openbox share/gnome/wm-properties
+ ${ECHO_CMD} @dirrm ${ii} >> ${PLIST}
.endfor
.for ii in la lai so so.1
${ECHO_CMD} lib/libobparser.${ii} >> ${PLIST}
@@ -81,10 +81,10 @@ pre-install:
.endif
do-install:
- ${MKDIR} ${DATADIR} ${PREFIX}/etc/openbox/xdg/openbox \
- ${PREFIX}/include/openbox/3.0
+ ${MKDIR} ${DATADIR} ${PREFIX}/share/gnome/wm-properties \
+ ${PREFIX}/etc/openbox/xdg/openbox ${PREFIX}/include/openbox
.for ii in parser/parse render/theme render/render
- ${INSTALL_DATA} ${WRKSRC}/${ii}.h ${PREFIX}/include/openbox/3.0
+ ${INSTALL_DATA} ${WRKSRC}/${ii}.h ${PREFIX}/include/openbox
.endfor
.for ii in parser render
${INSTALL_DATA} ${WRKSRC}/${ii}/ob${ii}-3.0.pc \