aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorrnoland <rnoland@FreeBSD.org>2010-02-16 01:40:51 +0800
committerrnoland <rnoland@FreeBSD.org>2010-02-16 01:40:51 +0800
commit9243d055a9fe3f06848e43272f67ac075db36444 (patch)
tree45a0c25690b1770d05672a656d8c3a7e4ee0f402 /x11-wm
parent0f6bc805f8704d1a2206a0597f84cc1fc67eb47c (diff)
downloadfreebsd-ports-gnome-9243d055a9fe3f06848e43272f67ac075db36444.tar.gz
freebsd-ports-gnome-9243d055a9fe3f06848e43272f67ac075db36444.tar.zst
freebsd-ports-gnome-9243d055a9fe3f06848e43272f67ac075db36444.zip
Fix build with or without the scandir changes.
Feature safe: yes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/libcompizconfig/Makefile12
-rw-r--r--x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp20
2 files changed, 30 insertions, 2 deletions
diff --git a/x11-wm/libcompizconfig/Makefile b/x11-wm/libcompizconfig/Makefile
index a8b3a3b7fa21..97b24281a03a 100644
--- a/x11-wm/libcompizconfig/Makefile
+++ b/x11-wm/libcompizconfig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libcompizconfig
PORTVERSION= 0.8.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
@@ -28,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
post-patch:
+ echo ${OSVERSION}
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
${WRKSRC}/src/main.c \
${WRKSRC}/src/lists.c \
@@ -35,4 +36,11 @@ post-patch:
${WRKSRC}/src/ini.c \
${WRKSRC}/backend/ini.c
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} < 800501) || \
+ (${OSVERSION} >= 900000 && ${OSVERSION} < 900006)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-compiz.cpp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp b/x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp
new file mode 100644
index 000000000000..e9a8e39aa3c3
--- /dev/null
+++ b/x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp
@@ -0,0 +1,20 @@
+--- src/compiz.cpp.orig 2009-03-04 21:22:22.000000000 -0600
++++ src/compiz.cpp 2009-04-06 01:58:35.000000000 -0500
+@@ -957,7 +957,7 @@
+
+
+ static int
+-pluginNameFilter (const struct dirent *name)
++pluginNameFilter (struct dirent *name)
+ {
+ int length = strlen (name->d_name);
+
+@@ -972,7 +972,7 @@
+ }
+
+ static int
+-pluginXMLFilter (const struct dirent *name)
++pluginXMLFilter (struct dirent *name)
+ {
+ int length = strlen (name->d_name);
+