aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-03-09 16:33:47 +0800
committerdougb <dougb@FreeBSD.org>2012-03-09 16:33:47 +0800
commitb60abbcf53f30ee07c212579357c2e09d74c0ee0 (patch)
treebb73218ca8d6de91677f5aa0b1d7fb6905cdc9a3 /x11-wm
parent6868fa9b92de990bad99e0036221b347667f47b9 (diff)
downloadfreebsd-ports-gnome-b60abbcf53f30ee07c212579357c2e09d74c0ee0.tar.gz
freebsd-ports-gnome-b60abbcf53f30ee07c212579357c2e09d74c0ee0.tar.zst
freebsd-ports-gnome-b60abbcf53f30ee07c212579357c2e09d74c0ee0.zip
Apparently xrandr affects the ability to restart a session negatively in
some circumstances. So make it optional, with a warning. Feature safe: yes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 614a9e01376b..e35c8be4e2e0 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -6,7 +6,7 @@
PORTNAME?= windowmaker
PORTVERSION= 0.95.2
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/ \
http://dougbarton.us/Downloads/
@@ -24,6 +24,8 @@ LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
.if !defined(LWR_SLAVE)
RUN_DEPENDS= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
USE_PERL5= yes
+
+OPTIONS= XRANDR "xrandr support (EXPERIMENTAL)" off
.endif
MAKE_JOBS_SAFE= yes
@@ -31,7 +33,7 @@ MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig
-USE_XORG= xft xinerama xmu xpm xrandr
+USE_XORG= xft xinerama xmu xpm
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -41,7 +43,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-libs-from="-L${LOCALBASE}/lib" \
--with-incs-from="-I${LOCALBASE}/include" \
--with-gnustepdir="${PREFIX}/GNUstep" \
- --enable-modelock --enable-xrandr \
+ --enable-modelock \
--enable-xinerama --enable-usermenu \
--with-x
USE_LDCONFIG= yes
@@ -54,6 +56,11 @@ USE_LDCONFIG= yes
CONFIGURE_ENV+= ac_cv_c_inline_asm=no
.endif
+.if defined(WITH_XRANDR)
+USE_XORG+= xrandr
+CONFIGURE_ARGS+= --enable-xrandr
+.endif
+
CONFLICTS= libwraster-0.*
MANLANG= "" cs ru sk
@@ -94,6 +101,6 @@ post-install:
update-LINGUAS: extract
cd ${WRKSRC}/po && \
${ECHO_CMD} *.po | ${SED} 's|\.po||g' > ${FILESDIR}/LINGUAS
-.endif
+.endif # .if !defined(LWR_SLAVE)
.include <bsd.port.post.mk>