aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorkbyanc <kbyanc@FreeBSD.org>2000-07-18 13:38:04 +0800
committerkbyanc <kbyanc@FreeBSD.org>2000-07-18 13:38:04 +0800
commitc3d76b0c64d6b2058cd24dc48d6d8c8f0e98294f (patch)
treeed12592dd2a9f1dd095b7a5971c9ba285562f6bb /x11-wm
parentd071d46e7ddf1eb9dbb1458e8eae91e178d4f969 (diff)
downloadfreebsd-ports-gnome-c3d76b0c64d6b2058cd24dc48d6d8c8f0e98294f.tar.gz
freebsd-ports-gnome-c3d76b0c64d6b2058cd24dc48d6d8c8f0e98294f.tar.zst
freebsd-ports-gnome-c3d76b0c64d6b2058cd24dc48d6d8c8f0e98294f.zip
New port: libepplet. This is the library portion of the existing epplets
port, the base library against which epplets must be linked. PR: 19396 Submitted by: kbyanc@posi.net
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/libepplet/Makefile31
-rw-r--r--x11-wm/libepplet/distinfo1
-rw-r--r--x11-wm/libepplet/pkg-comment1
-rw-r--r--x11-wm/libepplet/pkg-descr4
-rw-r--r--x11-wm/libepplet/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 1c91aa5479cb..574af65ca133 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -25,6 +25,7 @@
SUBDIR += icewm
SUBDIR += icewm-i18n
SUBDIR += libdockapp
+ SUBDIR += libepplet
SUBDIR += lwm
SUBDIR += mlvwm
SUBDIR += olvwm
diff --git a/x11-wm/libepplet/Makefile b/x11-wm/libepplet/Makefile
new file mode 100644
index 000000000000..dcbf26071c84
--- /dev/null
+++ b/x11-wm/libepplet/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libepplet
+# Date created: 18 October 1999
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libepplet
+PORTVERSION= 0.5
+CATEGORIES= x11-wm devel
+MASTER_SITES= ftp://ftp.enlightenment.org/e/epplets/
+DISTNAME= epplet-base-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+WRKSRC= ${WRKDIR}/Epplets-0.5
+
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-fsstd
+CONFIGURE_ENV= EROOT=${X11BASE}/share/enlightenment \
+ EBIN=${X11BASE}/bin \
+ LIBS="-L${LOCALBASE}/lib -lintl" \
+ X_LIBS="-lxpg4"
+
+MAKE_ENV= ${ECHO} -n; cd ${WRKSRC}/api;
+
+.include <bsd.port.mk>
diff --git a/x11-wm/libepplet/distinfo b/x11-wm/libepplet/distinfo
new file mode 100644
index 000000000000..72e5def07b72
--- /dev/null
+++ b/x11-wm/libepplet/distinfo
@@ -0,0 +1 @@
+MD5 (epplet-base-0.5.tar.gz) = 6be063dcff76dcdef0f2bfdba4cd111d
diff --git a/x11-wm/libepplet/pkg-comment b/x11-wm/libepplet/pkg-comment
new file mode 100644
index 000000000000..01858ce6f1cb
--- /dev/null
+++ b/x11-wm/libepplet/pkg-comment
@@ -0,0 +1 @@
+Library for building enlightenment dock applications
diff --git a/x11-wm/libepplet/pkg-descr b/x11-wm/libepplet/pkg-descr
new file mode 100644
index 000000000000..14bfa574c238
--- /dev/null
+++ b/x11-wm/libepplet/pkg-descr
@@ -0,0 +1,4 @@
+Library for building enlightenment dock applications.
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/x11-wm/libepplet/pkg-plist b/x11-wm/libepplet/pkg-plist
new file mode 100644
index 000000000000..a2dc768fa62c
--- /dev/null
+++ b/x11-wm/libepplet/pkg-plist
@@ -0,0 +1,5 @@
+include/epplet.h
+lib/libepplet.a
+lib/libepplet.la
+lib/libepplet.so
+lib/libepplet.so.1