aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-11-12 01:39:25 +0800
committerijliao <ijliao@FreeBSD.org>2002-11-12 01:39:25 +0800
commitfe5585ad5a32981f9fadad02f3c749798ad96978 (patch)
tree7fc8666974cfedf1af9c2c1550d01e0d1b8539cb /x11-wm
parentcd19be9bf65d9800bd45f805a8dea1c2dfbf525b (diff)
downloadfreebsd-ports-gnome-fe5585ad5a32981f9fadad02f3c749798ad96978.tar.gz
freebsd-ports-gnome-fe5585ad5a32981f9fadad02f3c749798ad96978.tar.zst
freebsd-ports-gnome-fe5585ad5a32981f9fadad02f3c749798ad96978.zip
fix malloc.h problem
PR: 45191 Submitted by: thinker@branda.to
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/epplets/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index 017ba147e285..9a17965b251f 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= import:${PORTSDIR}/graphics/ImageMagick
WRKSRC= ${WRKDIR}/Epplets-0.5
+USE_REINPLACE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -32,4 +33,7 @@ CONFIGURE_ENV= EROOT=${X11BASE}/share/enlightenment \
LIBS="-L${LOCALBASE}/lib -lintl" \
X_LIBS="-lxpg4"
+post-patch:
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/epplets/mbox.c
+
.include <bsd.port.mk>