aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-12-20 08:17:58 +0800
committerstas <stas@FreeBSD.org>2010-12-20 08:17:58 +0800
commita04c2abbc2f20d273e9cfb9962594683f553f9b0 (patch)
tree470c933ca69fbc5f2bb8a4de338ce0c370295eb3 /x11-wm
parent16b6a5066aaa798b9173893ef0f34d706d511486 (diff)
downloadfreebsd-ports-gnome-a04c2abbc2f20d273e9cfb9962594683f553f9b0.tar.gz
freebsd-ports-gnome-a04c2abbc2f20d273e9cfb9962594683f553f9b0.tar.zst
freebsd-ports-gnome-a04c2abbc2f20d273e9cfb9962594683f553f9b0.zip
- Add x11-wm/e17-module-eooorg, the OpenOffice.org preload module for e17.
Submitted by: Grzegorz Blach <magik@roorback.net> (via private email)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e17-module-eooorg/Makefile37
-rw-r--r--x11-wm/e17-module-eooorg/distinfo2
-rw-r--r--x11-wm/e17-module-eooorg/pkg-descr4
-rw-r--r--x11-wm/e17-module-eooorg/pkg-plist17
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 0ff892d0fa83..6ec58b865527 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -44,6 +44,7 @@
SUBDIR += e17-module-efm_nav
SUBDIR += e17-module-efm_path
SUBDIR += e17-module-efm_pathbar
+ SUBDIR += e17-module-eooorg
SUBDIR += e17-module-everything-mpris
SUBDIR += e17-module-everything-pidgin
SUBDIR += e17-module-everything-places
diff --git a/x11-wm/e17-module-eooorg/Makefile b/x11-wm/e17-module-eooorg/Makefile
new file mode 100644
index 000000000000..3aebb573d804
--- /dev/null
+++ b/x11-wm/e17-module-eooorg/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-eooorg
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eooorg
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= OpenOffice.org preload module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-eooorg/distinfo b/x11-wm/e17-module-eooorg/distinfo
new file mode 100644
index 000000000000..e7f08a459608
--- /dev/null
+++ b/x11-wm/e17-module-eooorg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/eooorg-20101003.tar.bz2) = 134817195319a17ee1e7400d0721cb9747ff081bc37a9cc26f10738facf83576
+SIZE (e17/eooorg-20101003.tar.bz2) = 495585
diff --git a/x11-wm/e17-module-eooorg/pkg-descr b/x11-wm/e17-module-eooorg/pkg-descr
new file mode 100644
index 000000000000..686dcada2e68
--- /dev/null
+++ b/x11-wm/e17-module-eooorg/pkg-descr
@@ -0,0 +1,4 @@
+Preloads the openoffice process to save start time
+with the costs of some memory.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-eooorg/pkg-plist b/x11-wm/e17-module-eooorg/pkg-plist
new file mode 100644
index 000000000000..21a11c6bfde0
--- /dev/null
+++ b/x11-wm/e17-module-eooorg/pkg-plist
@@ -0,0 +1,17 @@
+lib/enlightenment/modules/eooorg/module.desktop
+lib/enlightenment/modules/eooorg/e-module-eooorg.edj
+lib/enlightenment/modules/eooorg/%%E17_ARCH%%/module.so
+%%NLS%%lib/enlightenment/modules/eooorg/locale/it/LC_MESSAGES/eooorg.mo
+%%NLS%%lib/enlightenment/modules/eooorg/locale/de/LC_MESSAGES/eooorg.mo
+%%NLS%%lib/enlightenment/modules/eooorg/locale/fr/LC_MESSAGES/eooorg.mo
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/de/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/de
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/eooorg/locale
+@dirrm lib/enlightenment/modules/eooorg/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/eooorg
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment