aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-05-12 07:13:40 +0800
committertrevor <trevor@FreeBSD.org>2002-05-12 07:13:40 +0800
commitcc532f0a2799a9a2fbce620a92d5f824a484a1f2 (patch)
tree0e15acc09a5012c7d8c7890d89cfd058307ce4d3 /x11-wm
parent55f11eff31ceb46707b433296afd2f9366a31cb4 (diff)
downloadfreebsd-ports-gnome-cc532f0a2799a9a2fbce620a92d5f824a484a1f2.tar.gz
freebsd-ports-gnome-cc532f0a2799a9a2fbce620a92d5f824a484a1f2.tar.zst
freebsd-ports-gnome-cc532f0a2799a9a2fbce620a92d5f824a484a1f2.zip
Make links for i18n (cribbed from blackbox port). For some reason,
i18n is broken in this port, but this brings it closer to being correct.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/hackedbox/Makefile13
-rw-r--r--x11-wm/openbox/Makefile13
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-wm/hackedbox/Makefile b/x11-wm/hackedbox/Makefile
index da71ddca4613..3b40366b53f9 100644
--- a/x11-wm/hackedbox/Makefile
+++ b/x11-wm/hackedbox/Makefile
@@ -43,6 +43,9 @@ pre-install:
${ECHO_CMD} share/openbox/nls/${ii}/openbox.cat >> ${PLIST}
${ECHO_CMD} @dirrm share/openbox/nls/${ii} >> ${PLIST}
.endfor
+.for ii in POSIX US_ASCII de en en_US es fr it nl
+ ${ECHO_CMD} share/openbox/nls/${ii} >> ${PLIST}
+.endfor
.for ii in ${STYLES}
${ECHO_CMD} share/openbox/styles/${ii} >> ${PLIST}
.endfor
@@ -67,6 +70,16 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/nls/${ii}/openbox.cat \
${PREFIX}/share/openbox/nls/${ii}/
.endfor
+ cd ${PREFIX}/share/openbox/nls/ && \
+ ${LN} -s C POSIX && \
+ ${LN} -s C US_ASCII && \
+ ${LN} -s C en && \
+ ${LN} -s C en_US && \
+ ${LN} -s de_DE de && \
+ ${LN} -s es_ES es && \
+ ${LN} -s fr_FR fr && \
+ ${LN} -s it_IT it && \
+ ${LN} -s nl_NL nl
.for ii in ${STYLES}
${INSTALL_DATA} ${WRKSRC}/data/styles/${ii} \
${PREFIX}/share/openbox/styles/
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index da71ddca4613..3b40366b53f9 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -43,6 +43,9 @@ pre-install:
${ECHO_CMD} share/openbox/nls/${ii}/openbox.cat >> ${PLIST}
${ECHO_CMD} @dirrm share/openbox/nls/${ii} >> ${PLIST}
.endfor
+.for ii in POSIX US_ASCII de en en_US es fr it nl
+ ${ECHO_CMD} share/openbox/nls/${ii} >> ${PLIST}
+.endfor
.for ii in ${STYLES}
${ECHO_CMD} share/openbox/styles/${ii} >> ${PLIST}
.endfor
@@ -67,6 +70,16 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/nls/${ii}/openbox.cat \
${PREFIX}/share/openbox/nls/${ii}/
.endfor
+ cd ${PREFIX}/share/openbox/nls/ && \
+ ${LN} -s C POSIX && \
+ ${LN} -s C US_ASCII && \
+ ${LN} -s C en && \
+ ${LN} -s C en_US && \
+ ${LN} -s de_DE de && \
+ ${LN} -s es_ES es && \
+ ${LN} -s fr_FR fr && \
+ ${LN} -s it_IT it && \
+ ${LN} -s nl_NL nl
.for ii in ${STYLES}
${INSTALL_DATA} ${WRKSRC}/data/styles/${ii} \
${PREFIX}/share/openbox/styles/