aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2012-03-22 07:08:04 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2012-03-22 07:08:04 +0800
commit0b209dc61deb49a3246c71df42e46ea39a9770da (patch)
treee7d1b7843f675a0171ff4de51c7bc6d50d5107d7 /x11-wm
parenta3cb5079dcbc82aedee88cc7546d746f844ccffd (diff)
downloadfreebsd-ports-gnome-0b209dc61deb49a3246c71df42e46ea39a9770da.tar.gz
freebsd-ports-gnome-0b209dc61deb49a3246c71df42e46ea39a9770da.tar.zst
freebsd-ports-gnome-0b209dc61deb49a3246c71df42e46ea39a9770da.zip
- Fix hidden dependency on libinotify
- Link with libinotify correctly which fixes dependent ports dying with rtld error - Minor port cleanups PR: 166296 Submitted by: Ivan Klymenko <fidaj@ukr.net> Feature safe: yes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/libcompizconfig/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/x11-wm/libcompizconfig/Makefile b/x11-wm/libcompizconfig/Makefile
index be30298106d0..430b9c8c1047 100644
--- a/x11-wm/libcompizconfig/Makefile
+++ b/x11-wm/libcompizconfig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libcompizconfig
PORTVERSION= 0.8.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
@@ -27,14 +27,7 @@ USE_GNOME= gnomehack intltool libxml2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-post-patch:
- echo ${OSVERSION}
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
- ${WRKSRC}/src/main.c \
- ${WRKSRC}/src/lists.c \
- ${WRKSRC}/src/filewatch.c \
- ${WRKSRC}/src/ini.c \
- ${WRKSRC}/backend/ini.c
+OPTIONS= INOTIFY "Enable inotify support" on
.include <bsd.port.pre.mk>
@@ -43,4 +36,21 @@ post-patch:
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-compiz.cpp
.endif
+.if !defined(WITHOUT_INOTIFY)
+LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+LDFLAGS+= -linotify
+.endif
+
+post-patch:
+.if defined(WITHOUT_INOTIFY)
+ @${REINPLACE_CMD} -e 's|sys/inotify.h||' ${WRKSRC}/configure
+.endif
+ @echo "OSVERSION=${OSVERSION}"
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/src/main.c \
+ ${WRKSRC}/src/lists.c \
+ ${WRKSRC}/src/filewatch.c \
+ ${WRKSRC}/src/ini.c \
+ ${WRKSRC}/backend/ini.c
+
.include <bsd.port.post.mk>