aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-22 16:13:52 +0800
committerbapt <bapt@FreeBSD.org>2014-04-22 16:13:52 +0800
commit0e8e530896bc495d6ae451f0151edddf84a4a3f2 (patch)
tree81956cbabebf27c4de0a210c2a2d85289f278d46 /x11-wm
parentfb58d48733efcdc1e3ce20f86267148f520d454f (diff)
downloadfreebsd-ports-gnome-0e8e530896bc495d6ae451f0151edddf84a4a3f2.tar.gz
freebsd-ports-gnome-0e8e530896bc495d6ae451f0151edddf84a4a3f2.tar.zst
freebsd-ports-gnome-0e8e530896bc495d6ae451f0151edddf84a4a3f2.zip
Support stage
Cleanup a bit (this ports deserves either more love or death)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Makefile62
-rw-r--r--x11-wm/compiz/pkg-plist8
2 files changed, 24 insertions, 46 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 30f0e5ea3b43..a8de74605912 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -9,20 +9,20 @@ MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Compiz Composite/Window Manager
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- gtop-2.0.7:${PORTSDIR}/devel/libgtop \
- startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
+ libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
RUN_DEPENDS= glxinfo:${PORTSDIR}/graphics/mesa-demos \
nvidia-settings:${PORTSDIR}/x11/nvidia-settings
XORG_CAT= app
GNU_CONFIGURE= yes
-USES= gettext pathfix gmake tar:bzip2
+INSTALL_TARGET= install-strip
+USES= gettext pathfix gmake libtool tar:bzip2
USE_GL= glu
USE_GNOME= gconf2 libxslt
USE_XORG= xcomposite xfixes xdamage xrandr xrender ice sm xinerama glproto
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
GCONF_SCHEMAS= gwd.schemas \
compiz-annotate.schemas \
@@ -58,7 +58,7 @@ GCONF_SCHEMAS= gwd.schemas \
compiz-wobbly.schemas \
compiz-zoom.schemas
-CONFIGURE_ARGS= --disable-kde4
+CONFIGURE_ARGS= --disable-kde4 --disable-kde3
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
OPTIONS_DEFINE= SVG GTK2 METACITY GNOME DBUS FUSE
@@ -74,32 +74,17 @@ DESKTOP_ENTRIES= "Compiz Manager" \
"System;Core;" \
false
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|libpng|libpng15|' -e 's|gnome-desktop-2.0|gnome-desktop-2.0 gconf-2.0|g' \
- ${WRKSRC}/configure
+OPTIONS_SUB= yes
+SVG_CONFIGURE_ENABLE= librsvg
+SVG_USE= GNOME=librsvg2
-post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/compiz-manager ${PREFIX}/bin/compiz-manager
-.include <bsd.port.pre.mk>
+GTK2_CONFIGURE_ENABLE= gtk
+GTK2_USE= glib20 libwnck
-.if ${PORT_OPTIONS:MSVG}
-CONFIGURE_ARGS+= --enable-librsvg
-USE_GNOME+= librsvg2
-PLIST_SUB+= RSVG=""
-.else
-CONFIGURE_ARGS+= --disable-librsvg
-PLIST_SUB+= RSVG="@comment "
-.endif
+FUSE_CONFIGURE_ENABLE= fuse
+FUSE_USES= fuse
-.if ${PORT_OPTIONS:MGTK2}
-CONFIGURE_ARGS+= --enable-gtk
-USE_GNOME+= glib20 libwnck
-PLIST_SUB+= GTK2=""
-.else
-CONFIGURE_ARGS+= --disable-gtk
-PLIST_SUB+= GTK2="@comment "
-.endif
+.include <bsd.port.options.mk>
.if !empty(PORT_OPTIONS:MMETACITY) && !empty(PORT_OPTIONS:MGNOME) && !empty(PORT_OPTIONS:MGTK2)
CONFIGURE_ARGS+= --enable-metacity
@@ -134,22 +119,15 @@ CONFIGURE_ARGS+= --enable-dbus-glib
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
.endif
-PLIST_SUB+= DBUS=""
.else
CONFIGURE_ARGS+= --disable-dbus --disable-dbus-glib
-PLIST_SUB+= DBUS="@comment "
.endif
-.if ${PORT_OPTIONS:MFUSE}
-CONFIGURE_ARGS+= --enable-fuse
-USES+= fuse
-PLIST_SUB+= FUSE=""
-.else
-CONFIGURE_ARGS+= --disable-fuse
-PLIST_SUB+= FUSE="@comment "
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|libpng|libpng15|' -e 's|gnome-desktop-2.0|gnome-desktop-2.0 gconf-2.0|g' \
+ ${WRKSRC}/configure
-CONFIGURE_ARGS+= --disable-kde
-PLIST_SUB+= KDE3="@comment "
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/compiz-manager ${STAGEDIR}${PREFIX}/bin/compiz-manager
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/compiz/pkg-plist b/x11-wm/compiz/pkg-plist
index 1f34f7975ecf..f264f8acb94e 100644
--- a/x11-wm/compiz/pkg-plist
+++ b/x11-wm/compiz/pkg-plist
@@ -1,7 +1,6 @@
bin/compiz
bin/compiz-manager
%%GTK2%%bin/gtk-window-decorator
-%%KDE3%%bin/kde-window-decorator
include/compiz/compiz.h
include/compiz/compiz-common.h
include/compiz/compiz-core.h
@@ -78,9 +77,9 @@ lib/compiz/libscale.so
lib/compiz/libscreenshot.a
lib/compiz/libscreenshot.la
lib/compiz/libscreenshot.so
-%%RSVG%%lib/compiz/libsvg.a
-%%RSVG%%lib/compiz/libsvg.la
-%%RSVG%%lib/compiz/libsvg.so
+%%SVG%%lib/compiz/libsvg.a
+%%SVG%%lib/compiz/libsvg.la
+%%SVG%%lib/compiz/libsvg.so
lib/compiz/libswitcher.a
lib/compiz/libswitcher.la
lib/compiz/libswitcher.so
@@ -100,6 +99,7 @@ lib/libdecoration.a
lib/libdecoration.la
lib/libdecoration.so
lib/libdecoration.so.0
+lib/libdecoration.so.0.0.0
libdata/pkgconfig/compiz-cube.pc
libdata/pkgconfig/compiz-gconf.pc
libdata/pkgconfig/compiz-scale.pc