aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-22 03:13:53 +0800
committerpawel <pawel@FreeBSD.org>2014-12-22 03:13:53 +0800
commit192a9d4fe8bc80e5317086bf3d0f8594b87a81ac (patch)
tree7d5911530c769d1b7b150dcb015403652f744333 /x11-wm
parent875ed8a33dffde4abb50b9a283562fc2edc5ccc4 (diff)
downloadfreebsd-ports-gnome-192a9d4fe8bc80e5317086bf3d0f8594b87a81ac.tar.gz
freebsd-ports-gnome-192a9d4fe8bc80e5317086bf3d0f8594b87a81ac.tar.zst
freebsd-ports-gnome-192a9d4fe8bc80e5317086bf3d0f8594b87a81ac.zip
bspwm is a tiling window manager that represents windows as the leaves
of a full binary tree. It is controlled and configured via bspc. WWW: https://github.com/baskerville/bspwm PR: 196129 Submitted by: Anton Tornqvist <antont@inbox.lv>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/bspwm/Makefile26
-rw-r--r--x11-wm/bspwm/distinfo2
-rw-r--r--x11-wm/bspwm/files/patch-Makefile11
-rw-r--r--x11-wm/bspwm/pkg-descr4
-rw-r--r--x11-wm/bspwm/pkg-message10
-rw-r--r--x11-wm/bspwm/pkg-plist29
7 files changed, 83 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index ecffcf1dfd94..d8e222bcdf90 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -14,6 +14,7 @@
SUBDIR += bbkeys
SUBDIR += bbpager
SUBDIR += blackbox
+ SUBDIR += bspwm
SUBDIR += ccsm
SUBDIR += clementine
SUBDIR += compiz
diff --git a/x11-wm/bspwm/Makefile b/x11-wm/bspwm/Makefile
new file mode 100644
index 000000000000..d21c88da43dc
--- /dev/null
+++ b/x11-wm/bspwm/Makefile
@@ -0,0 +1,26 @@
+# Created by: Anton Törnqvist <antont@inbox.lv>
+# $FreeBSD$
+
+PORTNAME= bspwm
+PORTVERSION= 0.8.9
+CATEGORIES= x11-wm
+
+MAINTAINER= antont@inbox.lv
+COMMENT= Tiling window manager based on binary space partitioning
+
+LIB_DEPENDS= libxcb-icccm.so:${PORTSDIR}/x11/xcb-util-wm
+RUN_DEPENDS= sxhkd:${PORTSDIR}/x11/sxhkd
+
+USE_GITHUB= yes
+GH_ACCOUNT= baskerville
+GH_COMMIT= 1c5c3a1
+
+USES= gmake
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/x11-wm/bspwm/distinfo b/x11-wm/bspwm/distinfo
new file mode 100644
index 000000000000..e1e563f3ea0e
--- /dev/null
+++ b/x11-wm/bspwm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bspwm-0.8.9.tar.gz) = 841c9730ad16f63c74de0854bfc1eb1edb67baa6f6e797a1a8b59ec48929d249
+SIZE (bspwm-0.8.9.tar.gz) = 65651
diff --git a/x11-wm/bspwm/files/patch-Makefile b/x11-wm/bspwm/files/patch-Makefile
new file mode 100644
index 000000000000..6dd944ad21bc
--- /dev/null
+++ b/x11-wm/bspwm/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-12-15 20:58:41 UTC
++++ Makefile
+@@ -8,7 +8,7 @@ LDFLAGS += -L$(PREFIX)/lib
+
+ PREFIX ?= /usr/local
+ BINPREFIX = $(PREFIX)/bin
+-MANPREFIX = $(PREFIX)/share/man
++MANPREFIX = $(PREFIX)/man
+ BASHCPL = $(PREFIX)/share/bash-completion/completions
+ ZSHCPL = $(PREFIX)/share/zsh/site-functions
+
diff --git a/x11-wm/bspwm/pkg-descr b/x11-wm/bspwm/pkg-descr
new file mode 100644
index 000000000000..4f01f79dd68a
--- /dev/null
+++ b/x11-wm/bspwm/pkg-descr
@@ -0,0 +1,4 @@
+bspwm is a tiling window manager that represents windows as the leaves
+of a full binary tree. It is controlled and configured via bspc.
+
+WWW: https://github.com/baskerville/bspwm
diff --git a/x11-wm/bspwm/pkg-message b/x11-wm/bspwm/pkg-message
new file mode 100644
index 000000000000..bc58bb5a4ea7
--- /dev/null
+++ b/x11-wm/bspwm/pkg-message
@@ -0,0 +1,10 @@
+#######################################################################
+Copy the files bspwmrc and sxhkdrc from ${EXAMPLESDIR} to
+~/.config/bspwm/ and ~/.config/sxhkd/ and configure them as you wish.
+
+And add these lines to you .xinitrc:
+sxhkd &
+exec bspwm
+
+Then type startx from tty to run bspwm.
+#######################################################################
diff --git a/x11-wm/bspwm/pkg-plist b/x11-wm/bspwm/pkg-plist
new file mode 100644
index 000000000000..354f8eb501b8
--- /dev/null
+++ b/x11-wm/bspwm/pkg-plist
@@ -0,0 +1,29 @@
+bin/bspc
+bin/bspwm
+share/bash-completion/completions/bspc
+man/man1/bspc.1.gz
+man/man1/bspwm.1.gz
+share/zsh/site-functions/_bspc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sxhkdrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/external_rules
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/README.asciidoc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/bspwm_rules
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/external_rules
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/rulc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/external_rules/lua/ruld
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loop/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loop/sxhkdrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loop/profile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loop/wm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loop/xinitrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/overlapping_borders/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/bspwmrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/panel
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/panel_bar
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/panel_colors
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/panel_dzen2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/profile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panel/sxhkdrc