aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-03-18 10:54:26 +0800
committerdanfe <danfe@FreeBSD.org>2011-03-18 10:54:26 +0800
commit1ac043e34c36215337cf10c6e86abc02661a41a8 (patch)
treecbe56fb4d8470d9325018de41f529ec47252a587 /x11-wm
parentefb275ec725354bed0e0939e85a0f8c68818b583 (diff)
downloadfreebsd-ports-gnome-1ac043e34c36215337cf10c6e86abc02661a41a8.tar.gz
freebsd-ports-gnome-1ac043e34c36215337cf10c6e86abc02661a41a8.tar.zst
freebsd-ports-gnome-1ac043e34c36215337cf10c6e86abc02661a41a8.zip
- Replace direct (via LIB_DEPENDS) libXft dependency with USE_XORG one
- Optimize away `.for .. .endfor' loop when installing PORTDOCS - Wrap one overly long line, canonicalize Makefile header while here - Handle license installation via LICENSE framework Approved by: maintainer (earlier version of patch)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index e9065f1c0151..77c9644c0199 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -1,41 +1,40 @@
# New ports collection makefile for: Blackbox
-# Date created: June 15, 1998
-# Whom: Brian Handy <handy@physics.montana.edu>
+# Date created: June 15, 1998
+# Whom: Brian Handy <handy@physics.montana.edu>
#
# $FreeBSD$
#
PORTNAME= blackbox
PORTVERSION= 0.70.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}wm/${PORTNAME}wm/Blackbox%20${PORTVERSION}
MAINTAINER= A.J.Caines@halplant.com
COMMENT= A small and fast window manager for X11R6
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LICENSE= MIT
CONFLICTS= boxtools-*
-PORTDOCS= AUTHORS COMPLIANCE ChangeLog LICENSE README RELNOTES TODO
+PORTDOCS= AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO
MAN1= blackbox.1
-USE_GNOME= gnomehack pkgconfig
-USE_XORG= x11
GNU_CONFIGURE= yes
USE_ICONV= yes
+USE_GNOME= gnomehack pkgconfig
+USE_XORG= x11 xft
post-patch:
@${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' \
+ ${WRKSRC}/doc/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S#^#${WRKSRC}/#} ${DOCSDIR}
.endif
.include <bsd.port.mk>