aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-03-13 05:44:29 +0800
committeroliver <oliver@FreeBSD.org>2005-03-13 05:44:29 +0800
commit34f240713d682db3e41ce0726a6d5ca6ad9de55f (patch)
treee7d2e6edc3375bc489e71938229a644160068440 /x11-wm
parent7acdc86b7cae14775337ede8858788a0c144c6b9 (diff)
downloadfreebsd-ports-gnome-34f240713d682db3e41ce0726a6d5ca6ad9de55f.tar.gz
freebsd-ports-gnome-34f240713d682db3e41ce0726a6d5ca6ad9de55f.tar.zst
freebsd-ports-gnome-34f240713d682db3e41ce0726a6d5ca6ad9de55f.zip
fix build with gtk 2.6
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-desktop/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index f600ae4f37db..a6ebb2656bba 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -30,6 +30,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
@@ -38,4 +39,7 @@ CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
MAN1= xfdesktop.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_INLINE_FUNC||g' ${WRKSRC}/src/xfce-desktop.c
+
.include <bsd.port.mk>