aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-03-03 21:58:44 +0800
committerdanfe <danfe@FreeBSD.org>2005-03-03 21:58:44 +0800
commit789c12dda3fc79d8aa0579822f5e4daa54f7f7e2 (patch)
treef54c0534f8ae754e892ca6a62f8d7c9837b501c4 /x11-wm
parentcbdd10abcbaaf03815a2443a5ef7e2d93eefa775 (diff)
downloadfreebsd-ports-gnome-789c12dda3fc79d8aa0579822f5e4daa54f7f7e2.tar.gz
freebsd-ports-gnome-789c12dda3fc79d8aa0579822f5e4daa54f7f7e2.tar.zst
freebsd-ports-gnome-789c12dda3fc79d8aa0579822f5e4daa54f7f7e2.zip
Add waimea-devel, a highly customizable window manager with vector-based
style engine that takes advantage of display hardware acceleration. Base on PR: ports/74739 Submitted by: flz
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/waimea-devel/Makefile52
-rw-r--r--x11-wm/waimea-devel/distinfo2
-rw-r--r--x11-wm/waimea-devel/files/patch-src_Render.hh11
-rw-r--r--x11-wm/waimea-devel/files/patch-src_Resources.cc11
-rw-r--r--x11-wm/waimea-devel/files/patch-src_Screen.hh11
-rw-r--r--x11-wm/waimea-devel/files/patch-src_Waimea.cc11
-rw-r--r--x11-wm/waimea-devel/pkg-descr8
-rw-r--r--x11-wm/waimea-devel/pkg-plist60
9 files changed, 167 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index dea9c641168f..10ed4e3a1a99 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -98,6 +98,7 @@
SUBDIR += vtwm
SUBDIR += w9wm
SUBDIR += waimea
+ SUBDIR += waimea-devel
SUBDIR += wampager
SUBDIR += weewm
SUBDIR += windowlab
diff --git a/x11-wm/waimea-devel/Makefile b/x11-wm/waimea-devel/Makefile
new file mode 100644
index 000000000000..1f61aa362be8
--- /dev/null
+++ b/x11-wm/waimea-devel/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: Waimea
+# Date created: 03 Mar 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= waimea
+PORTVERSION= 0.5.0.20041204
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.ijs.si/~lesi/waimea/ \
+ http://www.daemon.li/distfiles/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= An X11 window manager designed for maximum efficiency
+
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
+ cairo.1:${PORTSDIR}/graphics/cairo
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= PNG "Enable PNG support" On \
+ SVG "Enable SVG support" On \
+ THREAD "Enable threading support" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --disable-png
+.endif
+
+.if defined(WITH_SVG)
+LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+.else
+CONFIGURE_ARGS+= --disable-svg
+.endif
+
+.if defined(WITH_THREAD)
+CONFIGURE_ARGS+= --enable-thread
+.endif
+
+MAN1= waimea.1
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/waimea-devel/distinfo b/x11-wm/waimea-devel/distinfo
new file mode 100644
index 000000000000..27e187ef9f26
--- /dev/null
+++ b/x11-wm/waimea-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (waimea-0.5.0.20041204.tar.bz2) = 2413cb52e0a24c946bfc87fa1647ccd0
+SIZE (waimea-0.5.0.20041204.tar.bz2) = 330165
diff --git a/x11-wm/waimea-devel/files/patch-src_Render.hh b/x11-wm/waimea-devel/files/patch-src_Render.hh
new file mode 100644
index 000000000000..93805dad784f
--- /dev/null
+++ b/x11-wm/waimea-devel/files/patch-src_Render.hh
@@ -0,0 +1,11 @@
+--- src/Render.hh.orig Thu Nov 4 06:22:46 2004
++++ src/Render.hh Thu Mar 3 18:19:13 2005
+@@ -28,6 +28,8 @@
+ #ifdef SVG
+ #include <svg-cairo.h>
+ #endif // SVG
++
++#include <X11/Xlib.h>
+ }
+
+ #include "RefCounted.hh"
diff --git a/x11-wm/waimea-devel/files/patch-src_Resources.cc b/x11-wm/waimea-devel/files/patch-src_Resources.cc
new file mode 100644
index 000000000000..bfbd18b0e169
--- /dev/null
+++ b/x11-wm/waimea-devel/files/patch-src_Resources.cc
@@ -0,0 +1,11 @@
+--- src/Resources.cc.orig Wed May 12 15:55:06 2004
++++ src/Resources.cc Thu Mar 3 19:21:58 2005
+@@ -171,7 +171,7 @@
+
+ __render_thread_count = 0;
+
+- if (value_str) {
++ if (value_str)
+ if (! strcasecmp("true", value_str))
+ __render_thread_count = 1;
+
diff --git a/x11-wm/waimea-devel/files/patch-src_Screen.hh b/x11-wm/waimea-devel/files/patch-src_Screen.hh
new file mode 100644
index 000000000000..d2d33e7b0e9c
--- /dev/null
+++ b/x11-wm/waimea-devel/files/patch-src_Screen.hh
@@ -0,0 +1,11 @@
+--- src/Screen.hh.orig Wed May 12 15:55:06 2004
++++ src/Screen.hh Wed Mar 2 19:58:43 2005
+@@ -25,6 +25,8 @@
+ extern "C" {
+ #include <X11/Xlib.h>
+
++#include <cairo-xlib.h>
++
+ #ifdef XINERAMA
+ # include <X11/extensions/Xinerama.h>
+ #endif // XINERAMA
diff --git a/x11-wm/waimea-devel/files/patch-src_Waimea.cc b/x11-wm/waimea-devel/files/patch-src_Waimea.cc
new file mode 100644
index 000000000000..14c249418399
--- /dev/null
+++ b/x11-wm/waimea-devel/files/patch-src_Waimea.cc
@@ -0,0 +1,11 @@
+--- src/Waimea.cc.orig Thu Nov 4 06:22:46 2004
++++ src/Waimea.cc Thu Mar 3 19:21:22 2005
+@@ -1151,7 +1151,7 @@
+ #ifdef THREAD
+ void *render_thread_func(void *) {
+ sigset_t sigset;
+- cairo_state_t *cr = cairo_create();
++ cairo_t *cr = cairo_create();
+
+ /* XXX: cairo need a call to this function for text support to be
+ initialized, will probably dissapear soon. */
diff --git a/x11-wm/waimea-devel/pkg-descr b/x11-wm/waimea-devel/pkg-descr
new file mode 100644
index 000000000000..0c1ccb54b7fb
--- /dev/null
+++ b/x11-wm/waimea-devel/pkg-descr
@@ -0,0 +1,8 @@
+Waimea is a highly customizable window manager for the X Window system
+conforming to the latest EWMH specification. Waimea supports multiple
+virtual desktops and by using the Cairo graphics library for all rendering,
+Waimea provides a modern vector-based style engine that takes advantage of
+display hardware acceleration when available (through the X Render
+Extension).
+
+WWW: http://waimea.org/wiki/Software_2fwaimea
diff --git a/x11-wm/waimea-devel/pkg-plist b/x11-wm/waimea-devel/pkg-plist
new file mode 100644
index 000000000000..abe35ab5cd85
--- /dev/null
+++ b/x11-wm/waimea-devel/pkg-plist
@@ -0,0 +1,60 @@
+bin/waimea
+bin/waimeactl
+%%DATADIR%%/actions/sloppyfocusopaque/action.conf
+%%DATADIR%%/actions/sloppyfocusnonopaque/action.conf
+%%DATADIR%%/actions/clicktofocusopaque/action.conf
+%%DATADIR%%/actions/clicktofocusnonopaque/action.conf
+%%DATADIR%%/actions/key-bindings.conf
+%%DATADIR%%/actions/button-mappings.conf
+%%DATADIR%%/actions/common.conf
+%%DATADIR%%/styles/freedesktop/style.conf
+%%DATADIR%%/styles/freedesktop/window.conf
+%%DATADIR%%/styles/freedesktop/menu.conf
+%%DATADIR%%/styles/freedesktop/dockapp.conf
+%%DATADIR%%/styles/freedesktop/root.conf
+%%DATADIR%%/styles/freedesktop/freedesktop.png
+%%DATADIR%%/styles/freedesktop/freedesktop.svg
+%%DATADIR%%/styles/logo.conf
+%%DATADIR%%/menus/icons/actions.png
+%%DATADIR%%/menus/icons/desktops.png
+%%DATADIR%%/menus/icons/editors.png
+%%DATADIR%%/menus/icons/emacs.png
+%%DATADIR%%/menus/icons/evolution.png
+%%DATADIR%%/menus/icons/exit.png
+%%DATADIR%%/menus/icons/galeon.png
+%%DATADIR%%/menus/icons/gimp.png
+%%DATADIR%%/menus/icons/graphics.png
+%%DATADIR%%/menus/icons/gvim.png
+%%DATADIR%%/menus/icons/info.png
+%%DATADIR%%/menus/icons/lock.png
+%%DATADIR%%/menus/icons/mozilla.png
+%%DATADIR%%/menus/icons/multimedia.png
+%%DATADIR%%/menus/icons/network.png
+%%DATADIR%%/menus/icons/restart.png
+%%DATADIR%%/menus/icons/rootmenu.png
+%%DATADIR%%/menus/icons/settings.png
+%%DATADIR%%/menus/icons/styles.png
+%%DATADIR%%/menus/icons/window-list.png
+%%DATADIR%%/menus/icons/window.png
+%%DATADIR%%/menus/icons/xmms.png
+%%DATADIR%%/menus/icons/xterm.png
+%%DATADIR%%/menus/menu.conf
+%%DATADIR%%/scripts/icons/styles.png
+%%DATADIR%%/scripts/icons/actions.png
+%%DATADIR%%/scripts/actioncfgmenu.pl
+%%DATADIR%%/scripts/stylecfgmenu.pl
+%%DATADIR%%/scripts/file2textop.pl
+%%DATADIR%%/waimearc
+%%DATADIR%%/waimea.dtd
+@dirrm %%DATADIR%%/styles/freedesktop
+@dirrm %%DATADIR%%/styles
+@dirrm %%DATADIR%%/scripts/icons
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/menus/icons
+@dirrm %%DATADIR%%/menus
+@dirrm %%DATADIR%%/actions/sloppyfocusopaque
+@dirrm %%DATADIR%%/actions/sloppyfocusnonopaque
+@dirrm %%DATADIR%%/actions/clicktofocusopaque
+@dirrm %%DATADIR%%/actions/clicktofocusnonopaque
+@dirrm %%DATADIR%%/actions
+@dirrm %%DATADIR%%