aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
commitb20f32bb38994e1bb5de05cecc229f10659e0f49 (patch)
treec350c4abc20ce22bda0b7dba0636816742669bc8 /x11-wm
parent20be128769eb36776631a3639656f9528820a14c (diff)
downloadfreebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.gz
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.zst
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.zip
- Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.h
and libintl.so. This fixes a problem where DATADIRNAME gets an incorrect value which causes locale files to be installed in the wrong place. - The only configure checks that still need to be patched are related to intltool so move DATADIRNAME patching from USES=pathfix to USE_GNOME=intlhack. - games/klavaro: remove excessive dependencies - japanese/libskk: add INSTALL_TARGET=install-strip - math/libqalculate: add INSTALL_TARGET=install-strip and remove pthread patching - multimedia/freetuxtv: remove excessive dependencies - science/gramps: fix shared-mime-info use Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Makefile3
-rw-r--r--x11-wm/plank/Makefile8
2 files changed, 7 insertions, 4 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index a3675f5bbf33..bf2e4f03da1d 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -60,7 +60,8 @@ GCONF_SCHEMAS= gwd.schemas \
compiz-zoom.schemas
CONFIGURE_ARGS= --disable-kde4 --disable-kde
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= SVG GTK2 METACITY GNOME DBUS FUSE
OPTIONS_DEFAULT= SVG GTK2 METACITY GNOME DBUS
diff --git a/x11-wm/plank/Makefile b/x11-wm/plank/Makefile
index e451ab6e67f0..e9fee96f38be 100644
--- a/x11-wm/plank/Makefile
+++ b/x11-wm/plank/Makefile
@@ -15,11 +15,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
LIB_DEPENDS= libbamf3.so:${PORTSDIR}/sysutils/bamf \
- libgee-0.8.so:${PORTSDIR}/devel/libgee
+ libgee-0.8.so:${PORTSDIR}/devel/libgee
-USES= tar:xz pkgconfig gmake pathfix libtool
+USES= tar:xz pkgconfig gmake pathfix libtool
GNU_CONFIGURE= yes
-USE_GNOME= glib20 gtk30 gdkpixbuf2 libxml2 libwnck3
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+USE_GNOME= glib20 gtk30 gdkpixbuf2 intlhack libxml2 libwnck3
USE_XORG= x11
INSTALLS_ICONS= yes
OPTIONS_SUB= yes