aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-04-01 04:21:49 +0800
committerdhn <dhn@FreeBSD.org>2009-04-01 04:21:49 +0800
commitbb040ff28a7d758dfee7b7ad42470967a75a74a5 (patch)
tree02f2516c915107af27670dd6d67355a738b0b38b /x11-wm
parent7f616126dc0f51e0984b6aa3eb2788593c5c9104 (diff)
downloadfreebsd-ports-gnome-bb040ff28a7d758dfee7b7ad42470967a75a74a5.tar.gz
freebsd-ports-gnome-bb040ff28a7d758dfee7b7ad42470967a75a74a5.tar.zst
freebsd-ports-gnome-bb040ff28a7d758dfee7b7ad42470967a75a74a5.zip
A simple dynamic window manager for X, with features nicked from
ratpoison and dwm. Musca's code is actually written from scratch, but a lot of useful stuff was gleaned from reading the source code of those two excellent projects. WWW: http://aerosuidae.net/musca.html Approved by: tabthorpe (co-mentor)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/musca/Makefile42
-rw-r--r--x11-wm/musca/distinfo3
-rw-r--r--x11-wm/musca/pkg-descr6
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/musca/Makefile b/x11-wm/musca/Makefile
new file mode 100644
index 000000000000..6cb2347488b8
--- /dev/null
+++ b/x11-wm/musca/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: musca
+# Date created: 2009-03-30
+# Whom: Dennis Herrmann <dhn@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= musca
+PORTVERSION= 0.9.13
+CATEGORIES= x11-wm
+MASTER_SITES= http://aerosuidae.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dhn@FreeBSD.org
+COMMENT= A simple window manager for X, with features from ratpoison and dwm
+
+RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
+
+USE_XORG= x11
+
+PLIST_FILES= bin/musca
+PORTDOCS= readme.txt
+
+pre-everything::
+ @${ECHO_MSG} "You can build musca with your own config.h using the MUSCA_CONF knob:"
+ @${ECHO_MSG} "make MUSCA_CONF=/path/to/musca/config.h install clean"
+
+post-extract:
+.if defined(MUSCA_CONF)
+ @${ECHO_MSG} "creating config.h from ${MUSCA_CONF}"
+ @${CP} ${MUSCA_CONF} ${WRKSRC}/config.h
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/musca/distinfo b/x11-wm/musca/distinfo
new file mode 100644
index 000000000000..23e8838540e4
--- /dev/null
+++ b/x11-wm/musca/distinfo
@@ -0,0 +1,3 @@
+MD5 (musca-0.9.13.tgz) = 0de3318238676483ad1a75550df6faa7
+SHA256 (musca-0.9.13.tgz) = 62c9f80473941da5da24efe1ffdde68a941f55dc7a53814eac6b35edac3366fa
+SIZE (musca-0.9.13.tgz) = 57881
diff --git a/x11-wm/musca/pkg-descr b/x11-wm/musca/pkg-descr
new file mode 100644
index 000000000000..94101c76fa20
--- /dev/null
+++ b/x11-wm/musca/pkg-descr
@@ -0,0 +1,6 @@
+A simple dynamic window manager for X, with features nicked from
+ratpoison and dwm. Musca's code is actually written from scratch,
+but a lot of useful stuff was gleaned from reading the source code
+of those two excellent projects.
+
+WWW: http://aerosuidae.net/musca.html