aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-02-11 21:51:48 +0800
committerasami <asami@FreeBSD.org>1995-02-11 21:51:48 +0800
commitf00f61ef610a8de3a2a910e987fb397bed2e1dd0 (patch)
tree24bbbb01a66b3966a65153402e4eaaad5f842bab /x11-wm
parent0707f721571142597f21951399e1bca2bfed70fe (diff)
downloadfreebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.tar.gz
freebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.tar.zst
freebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.zip
Converted Makefiles as much as I could.
(1) Took out INSTALL_MANPAGES (not necessary anymore, porter should set NO_INSTALL_MANPAGES for not calling "make install.man") (2) Replaced most of DEPENDS with EXEC_DEPENDS and LIB_DEPENDS. These are the entries I used: EXEC_DEPENDS: unzip:${PORTSDIR}/archivers/unzip gmake:${PORTSDIR}/devel/gmake wishx:${PORTSDIR}/lang/tclX xli:${PORTSDIR}/graphics/xli gs:${PORTSDIR}/print/ghostscript gunshar:${PORTSDIR}/archivers/gshar+gunshar hfs:${PORTSDIR}/utils/hfs rman:${PORTSDIR}/utils/rman LIB_DEPENDS: tiff\\.3\\.:${PORTSDIR}/graphics/tiff jpeg\\.5\\.:${PORTSDIR}/graphics/jpeg Xpm\\.4\\.:${PORTSDIR}/graphics/xpm tcl\\.7\\.:${PORTSDIR}/lang/tcl tk\\.3\\.:${PORTSDIR}/x11/tk xview\\.1\\.:${PORTSDIR}/x11/xview-lib Xaw3d\\.:${PORTSDIR}/x11/Xaw3d mpeg\\.1\\.:${PORTSDIR}/graphics/mpeg-lib xview\\.3\\.:${PORTSDIR}/x11/xview-lib BLT\\.1\\.:${PORTSDIR}/x11/blt There are still some dependencies I can't figure out what exactly is needed. If your port still has DEPENDS in it, please check it out!
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ctwm/Makefile4
-rw-r--r--x11-wm/fvwm/Makefile4
-rw-r--r--x11-wm/olvwm/Makefile2
-rw-r--r--x11-wm/piewm/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index 23a90fa338d8..8944a6ef4a31 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -3,7 +3,7 @@
# Date created: 13 November 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.3 1994/12/12 04:30:29 gpalmer Exp $
+# $Id: Makefile,v 1.4 1995/01/13 12:48:46 jkh Exp $
#
DISTNAME= ctwm-3.2p1
@@ -11,7 +11,7 @@ MASTER_SITES= ftp://ftp.x.org/contrib/window_managers/
USE_IMAKE= YES
EXTRACT_SUFX= .tar.Z
.if !exists(/usr/X11R6/lib/libXpm.a)
-DEPENDS= ${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
.endif
.include <bsd.port.mk>
diff --git a/x11-wm/fvwm/Makefile b/x11-wm/fvwm/Makefile
index ffd208d03047..d319ec8454d3 100644
--- a/x11-wm/fvwm/Makefile
+++ b/x11-wm/fvwm/Makefile
@@ -3,7 +3,7 @@
# Date created: 25 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1994/11/18 04:46:15 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/13 13:17:41 jkh Exp $
#
DISTNAME= fvwm
@@ -12,7 +12,7 @@ DISTFILES= fvwm-core.tar.gz fvwm-modules.tar.gz \
fvwm-icons.tar.gz
MASTER_SITES= ftp://spcot.sanders.com/pub/fvwm/
USE_IMAKE= yes
-DEPENDS= ${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
PKG_ARGS= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
-r ${PKGDIR}/REQUIRES -p ${PREFIX}
diff --git a/x11-wm/olvwm/Makefile b/x11-wm/olvwm/Makefile
index 1ca19a0f6024..7a0f6e453eac 100644
--- a/x11-wm/olvwm/Makefile
+++ b/x11-wm/olvwm/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX= .tar.Z
DISTFILES= olvwm4.tar.Z olvwm4.Patch01.Z
EXTRACT_ONLY= olvwm4.tar.Z
NO_WRKSUBDIR= yes
-DEPENDS= ${PORTSDIR}/x11/xview-lib
+LIB_DEPENDS= xview\\.3\\.:${PORTSDIR}/x11/xview-lib
pre-configure:
@echo "Applying olvwm4 Patch01"
diff --git a/x11-wm/piewm/Makefile b/x11-wm/piewm/Makefile
index 3420951ad0fd..dbcdb7cfcc80 100644
--- a/x11-wm/piewm/Makefile
+++ b/x11-wm/piewm/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 November 1994
# Whom: asami
#
-# $Id: Makefile,v 1.4 1995/01/05 05:54:47 asami Exp $
+# $Id: Makefile,v 1.5 1995/01/13 12:49:18 jkh Exp $
#
DISTNAME= piewm
@@ -11,7 +11,7 @@ USE_IMAKE= yes
MASTER_SITES= ftp://ftp.x.org/R5contrib/
EXTRACT_SUFX= .tar.Z
PKG_CMD= pkg_create -N
-DEPENDS= ${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
# piewm.tar.Z includes and old version of xpm, and also a bunch of .o
# files plus an executable