aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-04 14:34:17 +0800
committerbapt <bapt@FreeBSD.org>2012-10-04 14:34:17 +0800
commitf5e702222ae3308d71092729db463f8b4468944c (patch)
tree5781bc1bd8c4f084153e69bf465b0d7adba26979 /x11-wm
parent0dbc32d23f10f4fed472760dda6950e7ea72e73b (diff)
downloadfreebsd-ports-gnome-f5e702222ae3308d71092729db463f8b4468944c.tar.gz
freebsd-ports-gnome-f5e702222ae3308d71092729db463f8b4468944c.tar.zst
freebsd-ports-gnome-f5e702222ae3308d71092729db463f8b4468944c.zip
Convert to new options framework
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/x11-wm/stumpwm/Makefile b/x11-wm/stumpwm/Makefile
index cba1c13bacf0..5f97bda6e528 100644
--- a/x11-wm/stumpwm/Makefile
+++ b/x11-wm/stumpwm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: stumpwm
-# Date created: 2008-02-20
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= stumpwm
PORTVERSION= 0.9.7
@@ -28,16 +24,17 @@ INFO= ${PORTNAME}
PORTEXAMPLES= sample-stumpwmrc.lisp
PORTDATA= *
-OPTIONS= SBCL "Build with lang/sbcl (otherwise with lang/clisp)" on
+OPTIONS_DEFINE= SBCL EXAMPLES
+SBCL_DESC= Build with lang/sbcl (otherwise with lang/clisp)
.include <bsd.port.options.mk>
-.if defined(WITH_SBCL) || make(makesum) || defined(FETCH_ALL)
+.if ${PORT_OPTIONS:MSBCL} || make(makesum) || defined(FETCH_ALL)
MASTER_SITES+= http://common-lisp.net/~abridgewater/dist/clx/:clx
DISTFILES+= clx-0.7.4.tgz:clx
.endif
-.if defined(WITH_SBCL)
+.if ${PORT_OPTIONS:MSBCL}
CONFIGURE_ARGS+= --with-lisp=sbcl
BUILD_DEPENDS+= sbcl:${PORTSDIR}/lang/sbcl
.else
@@ -45,14 +42,14 @@ CONFIGURE_ARGS+= --with-lisp=clisp
BUILD_DEPENDS+= clisp:${PORTSDIR}/lang/clisp
.endif
-.if !defined(WITH_SBCL)
+.if empty(PORT_OPTIONS:MSBCL)
.if exists(${LOCALBASE}/bin/clisp) && \
!exists(${LOCALBASE}/lib/clisp/full/clx.o)
IGNORE= requires lang/clisp built with CLX_NEW option ON
.endif
.endif
-.if defined(WITH_SBCL)
+.if ${PORT_OPTIONS:MSBCL}
post-extract: .SILENT
${LN} -sf ${WRKDIR}/clx*/*.asd ${WRKSRC}/cl-ppcre/*.asd ${WRKSRC}
@@ -70,7 +67,7 @@ post-patch: .SILENT
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/stumpish ${PREFIX}/bin
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${EXAMPLESDIR}
.endif