aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-07 15:46:04 +0800
committerbapt <bapt@FreeBSD.org>2012-10-07 15:46:04 +0800
commitf641f09c5d05ea7c19ee2962402b83de81881944 (patch)
tree4d6e1fd6d93723c98a8482f71f13474f00567b33 /x11-wm
parent879ba80700cb4f1307491b845fb72c782f88b4d3 (diff)
downloadfreebsd-ports-gnome-f641f09c5d05ea7c19ee2962402b83de81881944.tar.gz
freebsd-ports-gnome-f641f09c5d05ea7c19ee2962402b83de81881944.tar.zst
freebsd-ports-gnome-f641f09c5d05ea7c19ee2962402b83de81881944.zip
Convert to new options framework
PR: ports/172414 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (maintainer)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/waimea-devel/Makefile21
-rw-r--r--x11-wm/waimea/Makefile20
2 files changed, 17 insertions, 24 deletions
diff --git a/x11-wm/waimea-devel/Makefile b/x11-wm/waimea-devel/Makefile
index fb0b0a13f6ef..0a48ceb4a834 100644
--- a/x11-wm/waimea-devel/Makefile
+++ b/x11-wm/waimea-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Waimea
-# Date created: 03 Mar 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= waimea
PORTVERSION= 0.5.1
@@ -32,19 +28,18 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= PNG "Enable PNG support" On \
- SVG "Enable SVG support" On \
- THREAD "Enable threading support" Off
+OPTIONS_DEFINE= PNG SVG THREADS
+OPTIONS_DEFAULT= PNG SVG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.else
CONFIGURE_ARGS+= --disable-png
.endif
-.if defined(WITH_SVG)
+.if ${PORT_OPTIONS:MSVG}
LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
.else
CONFIGURE_ARGS+= --disable-svg
@@ -52,7 +47,7 @@ MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.endif
-.if defined(WITH_THREAD)
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --enable-thread
.endif
@@ -63,4 +58,4 @@ post-extract:
@${LN} -fs ${AUTOMAKE_DIR}/${f} ${WRKSRC}/config/${f}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/waimea/Makefile b/x11-wm/waimea/Makefile
index 10027b2c156f..e8bd5c087d55 100644
--- a/x11-wm/waimea/Makefile
+++ b/x11-wm/waimea/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: waimea
-# Date created: 27 May 2002
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME= waimea
PORTVERSION= 0.4.0
@@ -27,17 +23,19 @@ GNU_CONFIGURE= yes
MAN1= waimea.1
-OPTIONS= PIXMAP "Build with pixmap textures support" on \
- DITHER "Enable ordered pseudocolor dithering" off
+OPTIONS_DEFINE= PIXMAP DITHER
+OPTIONS_DEFAULT= PIXMAP
+PIXMAP_DESC= Build with pixmap textures support
+DITHER_DESC= =Enable ordered pseudocolor dithering
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PIXMAP)
+.if ${PORT_OPTIONS:MPIXMAP}
USE_EFL+= imlib2
.endif
-.if defined(WITH_DITHER)
+.if ${PORT_OPTIONS:MDITHER}
CONFIGURE_ARGS+= --enable-ordered-pseudo
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>