aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-22 16:39:21 +0800
committermiwi <miwi@FreeBSD.org>2017-04-22 16:39:21 +0800
commitfedf8f5e369c8fcce59405a77709e65836823daa (patch)
treee5f625cdb00b266a744580a510d2e9f52276f471 /x11-wm
parent6e6d4ecb3bbf0cc76dd336b14613994990d7e601 (diff)
downloadfreebsd-ports-gnome-fedf8f5e369c8fcce59405a77709e65836823daa.tar.gz
freebsd-ports-gnome-fedf8f5e369c8fcce59405a77709e65836823daa.tar.zst
freebsd-ports-gnome-fedf8f5e369c8fcce59405a77709e65836823daa.zip
- Fix shebangs
- Add missing dependency Approved by: maintainer via irc
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index ec34457dd651..a9c49d64fdea 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openbox
PORTVERSION= 3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/openbox/
@@ -12,11 +12,16 @@ COMMENT= Small, fast, standards compliant, extensible window manager
LICENSE= GPLv2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig
-USE_GNOME= glib20 libxml2
-USE_XORG= xcursor xext xft xinerama xrandr xau
+USES= gmake libtool pathfix python:run pkgconfig shebangfix
+USE_GNOME= cairo glib20 libxml2
+USE_XORG= ice sm x11 xcursor xext xft xinerama xrandr \
+ xrender xau
USE_LDCONFIG= yes
+SHEBANG_FILES= data/autostart/openbox-xdg-autostart
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXext