aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-10-24 22:25:27 +0800
committerdinoex <dinoex@FreeBSD.org>2005-10-24 22:25:27 +0800
commit48ca936e85538cbfac3120263a53beb482f9a6c3 (patch)
treed93cec22eaae6d43145bf22b55d6d09b3bbe5e8e /x11-wm
parent8389c301c8b647fe8ddd440b15d21206c47b90d5 (diff)
downloadfreebsd-ports-gnome-48ca936e85538cbfac3120263a53beb482f9a6c3.tar.gz
freebsd-ports-gnome-48ca936e85538cbfac3120263a53beb482f9a6c3.tar.zst
freebsd-ports-gnome-48ca936e85538cbfac3120263a53beb482f9a6c3.zip
- make portlint happier
- honor PREFIX in defaults and sample.fvwmrc
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/Makefile7
-rw-r--r--x11-wm/fvwm/files/patch-ab10
-rw-r--r--x11-wm/fvwm/files/patch-ac8
3 files changed, 16 insertions, 9 deletions
diff --git a/x11-wm/fvwm/Makefile b/x11-wm/fvwm/Makefile
index 0bdf72db26d6..746605a1d08a 100644
--- a/x11-wm/fvwm/Makefile
+++ b/x11-wm/fvwm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fvwm
PORTVERSION= 1.24r
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.hpc.uh.edu/pub/fvwm/version-1/ \
ftp://ftp.ics.es.osaka-u.ac.jp/pub/CFAN/sources/1.x/
@@ -17,6 +18,7 @@ COMMENT= The fvwm window manager
NO_LATEST_LINK= yes
USE_IMAKE= yes
USE_XPM= yes
+USE_REINPLACE= yes
# must overwrite the default from bsd.port.mk
XMKMF= xmkmf
ALL_TARGET= Makefiles all
@@ -25,6 +27,11 @@ MAN1= FvwmAudio.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmClean.1 \
FvwmSaveDesk.1 FvwmScroll.1 FvwmWinList.1 GoodStuff.1 fvwm.1 \
xpmroot.1
+pre-configure:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/configure.h \
+ ${WRKSRC}/sample.fvwmrc/system.fvwmrc
+
post-install:
@${MKDIR} ${PREFIX}/include/X11/pixmaps
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 \
diff --git a/x11-wm/fvwm/files/patch-ab b/x11-wm/fvwm/files/patch-ab
index 0b2e7c2fda37..6fd353db208d 100644
--- a/x11-wm/fvwm/files/patch-ab
+++ b/x11-wm/fvwm/files/patch-ab
@@ -10,10 +10,10 @@
/* Imake command needed to put modules in desired target location */
/* Use the second version if it causes grief */
--- 1,7 ----
-! #define FVWMDIR "/usr/X11R6/lib/X11/fvwm"
+! #define FVWMDIR "%%PREFIX%%/lib/X11/fvwm"
/* #define FVWMDIR "/local/homes/dsp/nation/modules"*/
-! #define FVWM_ICONDIR "/usr/X11R6/include/X11/bitmaps:/usr/X11R6/include/X11/pixmaps"
-! #define FVWMRC "/usr/X11R6/lib/X11/fvwm/system.fvwmrc"
+! #define FVWM_ICONDIR "%%PREFIX%%/include/X11/bitmaps:%%PREFIX%%/include/X11/pixmaps"
+! #define FVWMRC "%%PREFIX%%/lib/X11/fvwm/system.fvwmrc"
/* Imake command needed to put modules in desired target location */
/* Use the second version if it causes grief */
@@ -36,7 +36,7 @@
* If you want to install it in a different directory, uncomment and
* edit the first line */
/* #define FVWM_BIN_DIR BINDIR=/local/homes/dsp/nation/bin/4.1.3*/
-! #define FVWM_BIN_DIR BINDIR=/usr/X11R6/bin
+! #define FVWM_BIN_DIR BINDIR=%%PREFIX%%/bin
/*#define FVWM_BIN_DIR*/
/* Compiler over-ride for Imakefiles */
@@ -48,7 +48,7 @@
/***************************************************************************
***************
*** 69,82 ****
- * undefine(`include') to fix that one. Some version of m4
+ * undefine(`include') tofix that one. Some version of m4
* seem to give good error messages, others don't?
***************************************************************************/
! /* #define M4 */
diff --git a/x11-wm/fvwm/files/patch-ac b/x11-wm/fvwm/files/patch-ac
index 889fb6b66b0d..ac93128be13e 100644
--- a/x11-wm/fvwm/files/patch-ac
+++ b/x11-wm/fvwm/files/patch-ac
@@ -27,9 +27,9 @@
-ModulePath /usr/lib/X11/fvwm
-PixmapPath /usr/include/X11/pixmaps/
-IconPath /usr/include/X11/bitmaps/
-+ModulePath /usr/X11R6/lib/X11/fvwm
-+PixmapPath /usr/X11R6/include/X11/pixmaps/
-+IconPath /usr/X11R6/include/X11/bitmaps/
++ModulePath %%PREFIX%%/lib/X11/fvwm
++PixmapPath %%PREFIX%%/include/X11/pixmaps/
++IconPath %%PREFIX%%/include/X11/bitmaps/
############################################################################
# Set the decoration styles and window options
@@ -38,7 +38,7 @@
Function "InitFunction"
Module "I" FvwmBanner
- Exec "I" xpmroot /usr/include/X11/pixmaps/fvwm.xpm &
-+ Exec "I" xpmroot /usr/X11R6/include/X11/pixmaps/fvwm.xpm &
++ Exec "I" xpmroot %%PREFIX%%/include/X11/pixmaps/fvwm.xpm &
Module "I" GoodStuff
Exec "I" exec xterm -geometry 80x64+0+0 &
Wait "I" xterm