aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-05 03:51:31 +0800
committermiwi <miwi@FreeBSD.org>2007-06-05 03:51:31 +0800
commit4e3f2cfe0577064eb9e89c1fe2574e0d7c5f9b87 (patch)
tree43016d8fe624878bf1a0386bce98770b6cbdb364 /x11-wm
parenta1215daa6f9b2f9c5bd2a001f874a4886ae3d151 (diff)
downloadfreebsd-ports-gnome-4e3f2cfe0577064eb9e89c1fe2574e0d7c5f9b87.tar.gz
freebsd-ports-gnome-4e3f2cfe0577064eb9e89c1fe2574e0d7c5f9b87.tar.zst
freebsd-ports-gnome-4e3f2cfe0577064eb9e89c1fe2574e0d7c5f9b87.zip
- Fix build with gcc4
- Update MASTER_SITES and WWW: line PR: 113306 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxspace/Makefile21
-rw-r--r--x11-wm/fluxspace/files/patch-src__PythonInterface.cc20
-rw-r--r--x11-wm/fluxspace/pkg-descr2
3 files changed, 29 insertions, 14 deletions
diff --git a/x11-wm/fluxspace/Makefile b/x11-wm/fluxspace/Makefile
index a5d6fee9796a..6a069fa28502 100644
--- a/x11-wm/fluxspace/Makefile
+++ b/x11-wm/fluxspace/Makefile
@@ -9,7 +9,7 @@ PORTNAME= fluxspace
PORTVERSION= 0.0.3
PORTREVISION= 3
CATEGORIES= x11-wm
-MASTER_SITES= http://www.isomedia.com/homes/stevencooper/files/
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A window manager and workspace enhancer and integrator
@@ -17,21 +17,16 @@ COMMENT= A window manager and workspace enhancer and integrator
BUILD_DEPENDS= imlib2-config:${PORTSDIR}/graphics/imlib2 \
swig:${PORTSDIR}/devel/swig13
-USE_AUTOTOOLS= libtool:15
+USE_XLIB= yes
USE_PYTHON= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_LDCONFIG= yes
-USE_XLIB= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
.if defined(WITH_IDESK) || exists(${X11BASE}/bin/idesk)
RUN_DEPENDS+= idesk:${PORTSDIR}/x11/idesk
.endif
@@ -40,10 +35,10 @@ RUN_DEPENDS+= rox:${PORTSDIR}/x11-fm/rox-filer
.endif
pre-everything::
- @${ECHO_CMD} "WITH_IDESK - To install idesk"
- @${ECHO_CMD} "WITH_ROX-FILER - To install rox-filer"
+ @${ECHO_MSG} "WITH_IDESK - To install idesk"
+ @${ECHO_MSG} "WITH_ROX-FILER - To install rox-filer"
-post-install::
- @${CAT} pkg-message
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11-wm/fluxspace/files/patch-src__PythonInterface.cc b/x11-wm/fluxspace/files/patch-src__PythonInterface.cc
new file mode 100644
index 000000000000..fd4ebd023953
--- /dev/null
+++ b/x11-wm/fluxspace/files/patch-src__PythonInterface.cc
@@ -0,0 +1,20 @@
+--- src/PythonInterface.cc.orig Fri Nov 22 15:24:42 2002
++++ src/PythonInterface.cc Sun May 27 01:16:12 2007
+@@ -256,7 +256,7 @@
+ class PythonInterfaceModule
+ {
+ public:
+- PythonInterfaceModule::PythonInterfaceModule(const string& name_, PyObject* config_)
++ PythonInterfaceModule(const string& name_, PyObject* config_)
+ : name(name_),
+ next(NULL),
+ module(name_),
+@@ -266,7 +266,7 @@
+ FSInitialize = new MyPyFunctionPtr(module.dict.GetItemString("fluxlet_main"));
+ }
+
+- PythonInterfaceModule::~PythonInterfaceModule()
++ ~PythonInterfaceModule()
+ {
+ delete FSInitialize;
+ }
diff --git a/x11-wm/fluxspace/pkg-descr b/x11-wm/fluxspace/pkg-descr
index 3e234353d4be..d159da18e3e5 100644
--- a/x11-wm/fluxspace/pkg-descr
+++ b/x11-wm/fluxspace/pkg-descr
@@ -7,4 +7,4 @@ desktop management to a pure window manager, such as Fluxbox. It goes beyond
the normal desktop capabilities to allow you to customize each workspace with
its own panels, desktop icons and running applets.
-WWW: http://www.isomedia.com/homes/stevencooper/projects/fluxspace.html
+WWW: http://fluxspace.sourceforge.net/