aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-06-05 10:02:35 +0800
committeralepulver <alepulver@FreeBSD.org>2007-06-05 10:02:35 +0800
commit7a08efe124f758e1d0979aabb991043e0ae58645 (patch)
treea0e45647b351cc56dd58094e05309ece2149ee43 /x11-wm
parentfaaf1594e57663f7bda6e9f4f461a9d285ef992c (diff)
downloadfreebsd-ports-gnome-7a08efe124f758e1d0979aabb991043e0ae58645.tar.gz
freebsd-ports-gnome-7a08efe124f758e1d0979aabb991043e0ae58645.tar.zst
freebsd-ports-gnome-7a08efe124f758e1d0979aabb991043e0ae58645.zip
- Fix SIGSEGV in TaskBarShowAPMStatus code, as per tracker #1629022:
https://sourceforge.net/tracker/?func=detail&atid=100031&aid=1629022&group_id=31 PR: ports/112880 Submitted by: Daniel Roethlisberger <daniel@roe.ch>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/Makefile2
-rw-r--r--x11-wm/icewm/files/patch-src_aapm.cc11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index e4968f624049..59ffb1c3ba72 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icewm
PORTVERSION= 1.2.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= SF
diff --git a/x11-wm/icewm/files/patch-src_aapm.cc b/x11-wm/icewm/files/patch-src_aapm.cc
new file mode 100644
index 000000000000..9ea7259be9a9
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src_aapm.cc
@@ -0,0 +1,11 @@
+--- src/aapm.cc.orig 2006/12/24 15:56:15 1.18.2.3
++++ src/aapm.cc 2007/04/22 16:38:49 1.18.2.4
+@@ -632,7 +632,7 @@
+
+ //estimate applet's size
+ for (i = 0; i < batteryNum; i++) {
+- if (acpiBatteries[i]->present == BAT_ABSENT)
++ if (mode == ACPI && acpiBatteries[i]->present == BAT_ABSENT)
+ continue;
+ if (taskBarShowApmTime)
+ strcat(buf, "0:00");