aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-08-24 01:50:09 +0800
committerflz <flz@FreeBSD.org>2007-08-24 01:50:09 +0800
commitce29ef2d24a2444e381db7f15c2020d77972fbe8 (patch)
tree25328ee0e04733ae5d8c58e9248b8a8971b74886 /x11-wm
parent6300f15afdd996e319dd52ba9061184632dea8b4 (diff)
downloadfreebsd-ports-gnome-ce29ef2d24a2444e381db7f15c2020d77972fbe8.tar.gz
freebsd-ports-gnome-ce29ef2d24a2444e381db7f15c2020d77972fbe8.tar.zst
freebsd-ports-gnome-ce29ef2d24a2444e381db7f15c2020d77972fbe8.zip
Enable schemas.
Submitted by: maintainer
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz-fusion-plugins-main/Makefile23
-rw-r--r--x11-wm/compiz-plugins-main/Makefile23
2 files changed, 44 insertions, 2 deletions
diff --git a/x11-wm/compiz-fusion-plugins-main/Makefile b/x11-wm/compiz-fusion-plugins-main/Makefile
index 3686e9642e4a..0ea75c30ca66 100644
--- a/x11-wm/compiz-fusion-plugins-main/Makefile
+++ b/x11-wm/compiz-fusion-plugins-main/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compiz-fusion-plugins-main
PORTVERSION= 0.5.2
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
@@ -30,8 +30,29 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
+GCONF_SCHEMAS= compiz-animation.schemas \
+ compiz-colorfilter.schemas \
+ compiz-expo.schemas \
+ compiz-ezoom.schemas \
+ compiz-imgjpeg.schemas \
+ compiz-neg.schemas \
+ compiz-opacify.schemas \
+ compiz-put.schemas \
+ compiz-resizeinfo.schemas \
+ compiz-ring.schemas \
+ compiz-snap.schemas \
+ compiz-text.schemas \
+ compiz-thumbnail.schemas \
+ compiz-wall.schemas \
+ compiz-winrules.schemas \
+ compiz-workarounds.schemas \
+ compiz-scaleaddon.schemas \
+ compiz-vpswitch.schemas \
+ compiz-shift.schemas
+
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --enable-schemas
.include <bsd.port.mk>
diff --git a/x11-wm/compiz-plugins-main/Makefile b/x11-wm/compiz-plugins-main/Makefile
index 3686e9642e4a..0ea75c30ca66 100644
--- a/x11-wm/compiz-plugins-main/Makefile
+++ b/x11-wm/compiz-plugins-main/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compiz-fusion-plugins-main
PORTVERSION= 0.5.2
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
@@ -30,8 +30,29 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
+GCONF_SCHEMAS= compiz-animation.schemas \
+ compiz-colorfilter.schemas \
+ compiz-expo.schemas \
+ compiz-ezoom.schemas \
+ compiz-imgjpeg.schemas \
+ compiz-neg.schemas \
+ compiz-opacify.schemas \
+ compiz-put.schemas \
+ compiz-resizeinfo.schemas \
+ compiz-ring.schemas \
+ compiz-snap.schemas \
+ compiz-text.schemas \
+ compiz-thumbnail.schemas \
+ compiz-wall.schemas \
+ compiz-winrules.schemas \
+ compiz-workarounds.schemas \
+ compiz-scaleaddon.schemas \
+ compiz-vpswitch.schemas \
+ compiz-shift.schemas
+
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --enable-schemas
.include <bsd.port.mk>