aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-03-24 19:20:57 +0800
committergarga <garga@FreeBSD.org>2006-03-24 19:20:57 +0800
commitdeaca3fdf5cb2d076da79ea569b6edf17363a884 (patch)
treeaf42216e348802155d922c296d0383f2cadd0717 /x11-wm
parent75701046a1ecadb77aeb79fd633ffc4f3f7efd22 (diff)
downloadfreebsd-ports-gnome-deaca3fdf5cb2d076da79ea569b6edf17363a884.tar.gz
freebsd-ports-gnome-deaca3fdf5cb2d076da79ea569b6edf17363a884.tar.zst
freebsd-ports-gnome-deaca3fdf5cb2d076da79ea569b6edf17363a884.zip
- Use -fPIC just where it's really needed
Submitted by: Johan van Selst <johans@stack.nl>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/bbconf/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-wm/bbconf/Makefile b/x11-wm/bbconf/Makefile
index 08bdeb52452a..90e6c7d98971 100644
--- a/x11-wm/bbconf/Makefile
+++ b/x11-wm/bbconf/Makefile
@@ -36,14 +36,14 @@ PLIST_DIRS= lib/bbconf/plugins lib/bbconf
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC -DPIC
-.endif
-
post-patch:
- @${PERL} -pi -e 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
- @${PERL} -pi -e 's|-O2 ||g ; \
+ @${REINPLACE_CMD} -e 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-O2 ||g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+ @${REINPLACE_CMD} -e '/^CXXFLAGS =/s/$$/ -fPIC/' \
+ ${WRKSRC}/bbconf/plugins/*/Makefile.in
+.endif
post-install:
.if !defined(NOPORTDOCS)