aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-10-29 15:33:00 +0800
committervs <vs@FreeBSD.org>2007-10-29 15:33:00 +0800
commitf3c43dfdfd36027b1ccab397d4d15ae7e3797179 (patch)
tree1cf2ec97b64799c6d968e71dc70d40c9dda0eb34 /x11-wm
parent0262e317832374239d6070e7d54b939fe1f7f83a (diff)
downloadfreebsd-ports-gnome-f3c43dfdfd36027b1ccab397d4d15ae7e3797179.tar.gz
freebsd-ports-gnome-f3c43dfdfd36027b1ccab397d4d15ae7e3797179.tar.zst
freebsd-ports-gnome-f3c43dfdfd36027b1ccab397d4d15ae7e3797179.zip
XMonad is a tiling window manager written in Haskell for X.
Features : * Very stable, fast, small and simple. * Automatic window tiling and management * First class keyboard support: a mouse is unnecessary * Full support for tiling windows on multi-head displays * Full support for floating windows * XRandR support to rotate, add or remove monitors * Per-workspace layout algorithms * Per-screens custom status bars * Easy, powerful customisation and reconfiguration * Large extension library * Extensive documentation and support for hacking WWW: http://www.xmonad.org/ PR: ports/117491 Submitted by: Matthieu Guegan <matt.guegan at free.fr>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/hs-xmonad/Makefile42
-rw-r--r--x11-wm/hs-xmonad/distinfo3
-rw-r--r--x11-wm/hs-xmonad/pkg-descr16
-rw-r--r--x11-wm/xmonad/Makefile42
-rw-r--r--x11-wm/xmonad/distinfo3
-rw-r--r--x11-wm/xmonad/pkg-descr16
7 files changed, 123 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 9c814fd47dd1..13e575fd9db4 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -143,6 +143,7 @@
SUBDIR += xfce4-panel
SUBDIR += xfce4-session
SUBDIR += xfce4-wm
+ SUBDIR += xmonad
SUBDIR += yawm
.include <bsd.port.subdir.mk>
diff --git a/x11-wm/hs-xmonad/Makefile b/x11-wm/hs-xmonad/Makefile
new file mode 100644
index 000000000000..d5f5b73ae58c
--- /dev/null
+++ b/x11-wm/hs-xmonad/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: xmonad
+# Date created: 2007-10-25
+# Whom: Matthieu Guegan <matt.guegan@free.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmonad
+PORTVERSION= 0.4
+CATEGORIES= x11-wm haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/xmonad/${PORTVERSION}/
+
+MAINTAINER= matt.guegan@free.fr
+COMMENT= Xmonad is a minimalist and tiling window manager for X
+
+USE_XLIB= yes
+
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-extras-ghc>=0.4:${PORTSDIR}/x11/hs-x11-extras-ghc
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+PLIST_FILES= bin/xmonad
+PORTDOCS= LICENSE
+MAN1= xmonad.1
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build
+
+do-install:
+ @cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_MAN} ${WRKSRC}/man/xmonad.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/hs-xmonad/distinfo b/x11-wm/hs-xmonad/distinfo
new file mode 100644
index 000000000000..3d7ece96fc6d
--- /dev/null
+++ b/x11-wm/hs-xmonad/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmonad-0.4.tar.gz) = 5d24c556f7c8f04954721b391fd79a13
+SHA256 (xmonad-0.4.tar.gz) = 978fb99e40786070307992fde78fe252b96e834740fb983b94c3a395c45467bb
+SIZE (xmonad-0.4.tar.gz) = 41025
diff --git a/x11-wm/hs-xmonad/pkg-descr b/x11-wm/hs-xmonad/pkg-descr
new file mode 100644
index 000000000000..a144dc5c9e7e
--- /dev/null
+++ b/x11-wm/hs-xmonad/pkg-descr
@@ -0,0 +1,16 @@
+XMonad is a tiling window manager written in Haskell for X.
+
+Features :
+ * Very stable, fast, small and simple.
+ * Automatic window tiling and management
+ * First class keyboard support: a mouse is unnecessary
+ * Full support for tiling windows on multi-head displays
+ * Full support for floating windows
+ * XRandR support to rotate, add or remove monitors
+ * Per-workspace layout algorithms
+ * Per-screens custom status bars
+ * Easy, powerful customisation and reconfiguration
+ * Large extension library
+ * Extensive documentation and support for hacking
+
+WWW: http://www.xmonad.org/
diff --git a/x11-wm/xmonad/Makefile b/x11-wm/xmonad/Makefile
new file mode 100644
index 000000000000..d5f5b73ae58c
--- /dev/null
+++ b/x11-wm/xmonad/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: xmonad
+# Date created: 2007-10-25
+# Whom: Matthieu Guegan <matt.guegan@free.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmonad
+PORTVERSION= 0.4
+CATEGORIES= x11-wm haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/xmonad/${PORTVERSION}/
+
+MAINTAINER= matt.guegan@free.fr
+COMMENT= Xmonad is a minimalist and tiling window manager for X
+
+USE_XLIB= yes
+
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-extras-ghc>=0.4:${PORTSDIR}/x11/hs-x11-extras-ghc
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+PLIST_FILES= bin/xmonad
+PORTDOCS= LICENSE
+MAN1= xmonad.1
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build
+
+do-install:
+ @cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_MAN} ${WRKSRC}/man/xmonad.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/xmonad/distinfo b/x11-wm/xmonad/distinfo
new file mode 100644
index 000000000000..3d7ece96fc6d
--- /dev/null
+++ b/x11-wm/xmonad/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmonad-0.4.tar.gz) = 5d24c556f7c8f04954721b391fd79a13
+SHA256 (xmonad-0.4.tar.gz) = 978fb99e40786070307992fde78fe252b96e834740fb983b94c3a395c45467bb
+SIZE (xmonad-0.4.tar.gz) = 41025
diff --git a/x11-wm/xmonad/pkg-descr b/x11-wm/xmonad/pkg-descr
new file mode 100644
index 000000000000..a144dc5c9e7e
--- /dev/null
+++ b/x11-wm/xmonad/pkg-descr
@@ -0,0 +1,16 @@
+XMonad is a tiling window manager written in Haskell for X.
+
+Features :
+ * Very stable, fast, small and simple.
+ * Automatic window tiling and management
+ * First class keyboard support: a mouse is unnecessary
+ * Full support for tiling windows on multi-head displays
+ * Full support for floating windows
+ * XRandR support to rotate, add or remove monitors
+ * Per-workspace layout algorithms
+ * Per-screens custom status bars
+ * Easy, powerful customisation and reconfiguration
+ * Large extension library
+ * Extensive documentation and support for hacking
+
+WWW: http://www.xmonad.org/
/cgit/cgit.cgi/freebsd-ports-gnome/commit/vietnamese?h=gnome-3.24&id=b99521534c12d8d1c82152ad1ddfca534761ad86'>Deprecate ports broken for more than 6 monthsantoine2014-10-261-0/+2 * KDE/FreeBSD team presents KDE SC 4.14.2 and KDE Workspace 4.11.13!makc2014-10-192-3/+4 * Update to 4.3.2.jkim2014-10-172-5/+4 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-112-1/+2 * Remove non staged ports without pending PR from textproc and vietnamesebapt2014-09-0223-923/+0 * Mark BROKEN: Fails to installantoine2014-08-311-0/+2 * Upgrade OpenEXR and ilmbase to 2.2.0.mandree2014-08-161-0/+1 * - Fix build with clang (functions not returing value)pawel2014-08-087-20/+20 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Remove indefinite articles and trailing periods from COMMENT, plusolgeni2014-08-032-2/+2 * Convert some more USE_BZIP2 to USES=tar:bzip2adamw2014-07-301-1/+1 * Rename vietnamese/ patch-xy patches to reflect the files they modify.adamw2014-07-296-0/+0 * vietnamese/libviet: Fix last commitmarino2014-07-291-1/+1 * vietnamese/libviet: respect CC/CFLAGSmarino2014-07-281-0/+2 * vietnamese/vnroff: integrate pkg-plist and cleanup makefilemarino2014-07-282-8/+8 * - Add LICENSEsunpoet2014-07-171-0/+2 * 1: remove NO_STAGE.vanilla2014-07-161-2/+1 * Resetting maintainership on ports that have not been staged and without anybapt2014-07-035-5/+5 * Stagify.vanilla2014-07-024-22/+32 * Update to 4.2.5.jkim2014-06-241-4/+4 * Update to libreoffice 4.2.4bapt2014-06-111-4/+4 * vietnamese/vis2u: Fix EXTRACT_AFTER_ARGSmarino2014-06-011-2/+1 * vietnamese/unicode-uhoai: Fix deinstall and add stage supportmarino2014-05-313-10/+19 * KDE/FreeBSD team presents KDE SC 4.12.5 and KDE Workspace 4.11.9!makc2014-05-111-2/+2 * Update to 4.1.6.jkim2014-05-071-4/+4 * Mark broken: Conflicts with dependency vnpstext on share/vn-fonts/initcour.psantoine2014-04-061-0/+2 * KDE/FreeBSD team presents KDE SC 4.12.4 and KDE Workspace 4.11.8!makc2014-04-031-2/+2 * Support stagingehaupt2014-03-172-10/+12 * Stagify, generally cleanup Makefile, provide more useful port description.danfe2014-03-162-17/+23 * Support stagingehaupt2014-03-132-6/+5 * Unbreakantoine2014-03-121-1/+1 * Unbreakantoine2014-03-121-1/+1 * Convert u* and v* to USES=zipbapt2014-03-117-7/+7 * KDE/FreeBSD team presents KDE SC 4.12.3 and KDE Workspace 4.11.7!makc2014-03-051-2/+2 * Support stagingehaupt2014-02-271-4/+2 * - Stage supportmiwi2014-02-263-7/+6 * Update to 4.1.5. It is partially based on the following PR.jkim2014-02-261-4/+4 * KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!makc2014-02-183-6/+23 * Fix properties on pkg-plistbapt2014-01-2210-10/+0 * Support stagebapt2014-01-203-7/+5 * - Use single space after WWW:sunpoet2013-11-181-1/+1 * Support stage, use bsdtar to extractbapt2013-11-041-4/+3 * Stagifybapt2013-11-041-1/+0 * - Update to 4.0.6.jkim2013-10-262-5/+4 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-2121-110/+39 * Update to 4.0.5.jkim2013-08-231-4/+4 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-275-369/+0 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-101-2/+1 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-051-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * Update to 4.0.4.jkim2013-06-201-4/+4 * - Fix ttfm's xttfm module to really update fonts.{dir,scale} to reflectrafan2013-06-204-4/+4 * Fix build with clangbapt2013-05-271-2/+11 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Rectify USE_TEX to support both of teTeX and TeXLive.hrs2013-05-121-1/+1 * Update to 4.0.3.jkim2013-05-101-4/+4 * Remove *_DEPENDS from ports which depend on teTeX and add USE_TEX=tetexhrs2013-05-061-3/+1 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * Update to 4.0.2.jkim2013-04-171-4/+4 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-273-5/+12 * 2013-03-05 ftp/proma: Broken for more than 6 monthbapt2013-03-1033-2132/+0 * Update to 4.0.1.jkim2013-03-092-5/+5 * Mark as deprecated a bunch of ports that are marked as broken for more than 6bapt2013-02-052-12/+8 * Update to 3.6.5.jkim2013-02-051-4/+4 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-043-9/+13 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * - Update to 3.5.7.jkim2012-10-272-9/+4 * - Update to 3.5.6.jkim2012-08-241-4/+4 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-181-4/+4 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-011-4/+4 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-151-2/+2 * - update png to 1.5.10dinoex2012-06-012-2/+2 * Fix CATEGORIESmakc2012-05-251-1/+1 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-255-0/+248 * Add the forgotten categoriesbapt2012-04-231-0/+1 * - upgrade to 3.5.2bapt2012-04-234-0/+21 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-3/+0 * Provide a new MASTER_SITE.obrien2011-10-062-8/+6 * Turns out that some geocities sites are more dead than others.dougb2011-08-242-2/+2 * Geocities has been gone for almost 2 years now, so let's removedougb2011-08-234-4/+6 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-2/+3 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-182-4/+4 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-3/+3 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * Bye bye abandonwares (part 5)bapt2011-08-015-52/+0 * - Sort SUBDIRssunpoet2011-08-011-1/+1 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-291-8/+8 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-221-1/+1 * Add vietnamese hunspell dictionnarybapt2011-07-204-0/+37 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-081-1/+1 * - Kick MD5 supportmiwi2011-07-032-2/+0 * Last bunch of deprecation: no more public distfiles and/or abandonware... las...bapt2011-06-171-0/+3 * Bump PORTREVISION after open-mofit updatemakc2011-05-021-1/+1 * - Get Rid MD5 supportmiwi2011-03-1919-20/+0 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-092-2/+0 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-161-2/+1 * UniKey is a very small and easy-to-use Vietnamese keyboard for Windows.pav2010-08-134-0/+33 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-311-1/+1 * - update to 1.4.1dinoex2010-03-284-4/+4 * - update to jpeg-8dinoex2010-02-054-4/+4 * - Mark MAKE_JOBS_UNSAFEpav2009-11-231-0/+1 * Reset chinsan@FreeBSD.org due to numerous maintainer-timeouts and nolinimon2009-08-295-5/+5 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-223-6/+3 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-313-2/+3 * Convert most of remaining ports that depend on xorg-libraries toamdmi32009-06-091-1/+2 * - fix plist with -DNOPORTDOCSitetcu2009-04-212-6/+6 * Remove file that does not seem to serve any purposepav2009-01-071-1/+0 * - utf8locale part of base system since 5.3pav2009-01-061-7/+1 * - use DOCSDIRitetcu2008-11-222-5/+6 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-291-3/+3 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-181-3/+3 * Mark BROKEN on HEAD: does not build.erwin2008-08-132-1/+11 * - Remove USE_GCC where it can be satisfied with base compiler on followingpav2008-07-251-1/+0 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-063-2/+3 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-205-16/+16 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-221-2/+1 * - Add MASTER_SITES.chinsan2008-03-011-1/+1 * Tweak the PR 119107 changes.obrien2008-02-032-18/+46 * Use termios instead of sgtty.obrien2008-01-222-2/+65 * Update to KDE 3.5.8lofi2007-10-301-3/+3 * Fix gcc4 build.obrien2007-08-243-5/+25 * Respect LOCALBASE.tdb2007-07-101-1/+1 * Update to KDE 3.5.7 / KOffice 1.6.3lofi2007-07-042-4/+3 * - Welcome X.org 7.2 \o/.flz2007-05-2011-2/+11 * Update to KDE 3.5.6 / KOffice 1.6.2lofi2007-03-142-3/+54 * Really normalize Aspell dictionaries ports PKGVERSION...thierry2007-02-151-1/+1 * - Update to 3.04rafan2007-02-042-11/+24 * Add urwvn 3.02, vietnamese version of the standard PostScript fonts fromrafan2007-01-284-0/+44 * Add gtk-im-vi 0.1.1, simple GTK+ input methods for Vietnamese(VNI andrafan2007-01-285-0/+50 * Normalize Aspell dictionaries PKGNAMEs.thierry2007-01-141-0/+1 * Add vietunicode-trichlor 2004.04.30, 100% Viet Unicode compatible.rafan2007-01-084-0/+69 * Add vietunicode-hannom 2005.02.06, UNICODE Han Nom Font Set.rafan2007-01-084-0/+50 * Add vietunicode-web1 2004.04.30, 100% Viet Unicode & Vietrafan2007-01-084-0/+53 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-201-3/+3 * - Respect X11BASErafan2006-12-022-15/+12