aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-13 01:34:18 +0800
committerbapt <bapt@FreeBSD.org>2013-06-13 01:34:18 +0800
commit0eeaacaa365a1fb5b63a92887bd38568c8983fb6 (patch)
tree930037d6329a0e3536128d8efa081946d69e227f /x11-wm
parentc43c13d78974fa7e9a1b07f22012a108aa4eb8b1 (diff)
downloadfreebsd-ports-gnome-0eeaacaa365a1fb5b63a92887bd38568c8983fb6.tar.gz
freebsd-ports-gnome-0eeaacaa365a1fb5b63a92887bd38568c8983fb6.tar.zst
freebsd-ports-gnome-0eeaacaa365a1fb5b63a92887bd38568c8983fb6.zip
Fix build with clang
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index a109c0dadbbb..09c4ce7254a8 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -22,6 +22,7 @@ MANCOMPRESSED= yes
MAN1= afterstep.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
CONFLICTS?= afterstep-2*
PORTSCOUT= limit:^1\.[0-9.]*$$
+CFLAGS+= -Wno-return-type
SRCDIRS= afterstep \
modules/Animate modules/Audio modules/Auto \
@@ -33,6 +34,9 @@ post-patch:
-e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/configure.h \
${WRKSRC}/sample.steprc
+ ${REINPLACE_CMD} \
+ -e 's/__inline__//g' \
+ ${WRKSRC}/configure.h
@ for i in ${SRCDIRS}; do \
cd ${WRKSRC}/$$i; \
${MV} Imakefile Imakefile.orig; \