aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-01-23 21:50:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-01-23 21:50:19 +0800
commit144161a0a41485d991484af40c0e900b7452c701 (patch)
tree852ff24249a0dfba9a0b2450192393879e0c13aa /x11-wm
parentaccd911ed0ef4cb1fc7a0a4447f34eed4a62da2a (diff)
downloadfreebsd-ports-gnome-144161a0a41485d991484af40c0e900b7452c701.tar.gz
freebsd-ports-gnome-144161a0a41485d991484af40c0e900b7452c701.tar.zst
freebsd-ports-gnome-144161a0a41485d991484af40c0e900b7452c701.zip
Fix build on amd64, 10.x with clang.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-panel/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index ccb7506f95e3..beafcfa64273 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libwnck-1.so:${PORTSDIR}/x11-toolkits/libwnck \
libcairo.so:${PORTSDIR}/graphics/cairo \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-USES= desktop-file-utils gmake pathfix perl5 pkgconfig
+USES= desktop-file-utils gmake pathfix perl5 pkgconfig compiler
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
@@ -28,7 +28,13 @@ CONFIGURE_ARGS+=--enable-gio-unix
OPTIONS_DEFINE= NLS DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1000000
+.if ${COMPILER_TYPE} == clang
+CFLAGS_amd64= -fPIC
+.endif
+.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
@@ -47,4 +53,4 @@ CONFIGURE_ARGS+=--without-html-dir
PLIST_SUB+= APIDOCS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>