aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-27 23:17:26 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-27 23:17:26 +0800
commitd56efc9c221a1d842e2d94bc4a974a384e0c812c (patch)
treef3f7b9324d9c9494194594bd3988fec89115e7cc /x11-wm
parent9a6adb833338ef239eaf48652caa0d7c8dadf82d (diff)
downloadfreebsd-ports-gnome-d56efc9c221a1d842e2d94bc4a974a384e0c812c.tar.gz
freebsd-ports-gnome-d56efc9c221a1d842e2d94bc4a974a384e0c812c.tar.zst
freebsd-ports-gnome-d56efc9c221a1d842e2d94bc4a974a384e0c812c.zip
Import a bunch of iconv fixes.
Submitted by: marino Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/Makefile1
-rw-r--r--x11-wm/awesome2/Makefile1
-rw-r--r--x11-wm/blackbox/Makefile1
-rw-r--r--x11-wm/i3/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 2d13c6a34878..9d70efc2981f 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -41,6 +41,7 @@ USE_GNOME= glib20 pango
USE_LUA= 5.1+
USE_XORG= pixman x11 xau xcb xdmcp xext xft xinerama xrandr xrender \
xproto
+LDFLAGS+= ${ICONV_LIB}
MAN1= awesome.1 \
awesome-client.1
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index eae453221d88..a74855481fa8 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
USE_EFL= imlib2
USE_GNOME= pango
USE_XORG= x11 xft xext xinerama xt xrandr xproto
+LDFLAGS+= -lX11 -lXext ${ICONV_LIB}
MAN1= awesome2.1 \
awesome2-client.1 \
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 7cc82d09066c..154fe7e7dfec 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -15,6 +15,7 @@ LICENSE= MIT
GNU_CONFIGURE= yes
USES= pathfix pkgconfig iconv
USE_XORG= x11 xft
+LDFLAGS+= ${ICONV_LIB}
MAN1= bsetbg.1 bsetroot.1
PORTDOCS= README.bbtools README.bsetbg
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index ccc081707526..b9f7257604fe 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -29,6 +29,7 @@ USE_XORG= x11 xcb xcursor
USES= pkgconfig iconv gmake perl5
USE_BZIP2= yes
USE_PERL5= run
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
MAKE_JOBS_UNSAFE= yes
post-patch: