aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-11-10 05:30:49 +0800
committerbapt <bapt@FreeBSD.org>2016-11-10 05:30:49 +0800
commit5b295a78c0c927432c8d6b4defceea41ed0f13d8 (patch)
tree8267632a1dfeaaa05ba056963264eff57fbe3c18 /x11-wm
parenta13acbe0b6179e8d8b6dda25c65b9249a078276e (diff)
downloadfreebsd-ports-gnome-5b295a78c0c927432c8d6b4defceea41ed0f13d8.tar.gz
freebsd-ports-gnome-5b295a78c0c927432c8d6b4defceea41ed0f13d8.tar.zst
freebsd-ports-gnome-5b295a78c0c927432c8d6b4defceea41ed0f13d8.zip
Update to 4.13
Changes: http://i3wm.org/downloads/RELEASE-NOTES-4.13.txt
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/Makefile33
-rw-r--r--x11-wm/i3/distinfo5
-rw-r--r--x11-wm/i3/files/patch-configure11
-rw-r--r--x11-wm/i3/files/patch-libi3_get__config__path.c11
4 files changed, 34 insertions, 26 deletions
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index d519fab59a6a..318cf2d1b650 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= i3
-DISTVERSION= 4.12
+DISTVERSION= 4.13
CATEGORIES= x11-wm
MASTER_SITES= http://i3wm.org/downloads/
@@ -21,38 +21,23 @@ LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libpangocairo-1.0.so:x11-toolkits/pango \
libpcre.so:devel/pcre \
libxcb-cursor.so:x11/xcb-util-cursor \
- libxkbcommon.so:x11/libxkbcommon
+ libxkbcommon.so:x11/libxkbcommon \
+ libxcb-xrm.so:x11/xcb-util-xrm
RUN_DEPENDS= p5-IPC-Run>=0:devel/p5-IPC-Run \
p5-Try-Tiny>=0:lang/p5-Try-Tiny \
p5-AnyEvent-I3>=0:devel/p5-AnyEvent-I3
USE_XORG= xcb
-USES= pkgconfig iconv gmake perl5 tar:bzip2
+USES= pkgconfig gmake iconv perl5 tar:bzip2
+GNU_CONFIGURE= yes
+CONFIGURE_OUTSOURCE= yes
+CONFIGURE_ENV= ac_cv_path_PATH_ASCIIDOC=""
USE_PERL5= run
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-MAKE_JOBS_UNSAFE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/src/config.c
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/i3.config
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/i3.config
- @${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}/|g' ${WRKSRC}/man/Makefile
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/man/i3.1
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/man/i3-msg.1
- @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' ${WRKSRC}/man/i3-input.1
- @${REINPLACE_CMD} -e 's|.SILENT||g' ${WRKSRC}/common.mk
- @${REINPLACE_CMD} -e 's|-Iinclude|-Iinclude -Isrc|g' \
- -e 's|-liconv|${ICONV_LIB}|' \
- -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/common.mk
+INSTALL_TARGET= install-strip
post-install:
@${INSTALL_DATA} ${WRKSRC}/man/*.1 ${STAGEDIR}${MANPREFIX}/man/man1/
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/i3 \
- ${STAGEDIR}${PREFIX}/bin/i3bar \
- ${STAGEDIR}${PREFIX}/bin/i3-config-wizard \
- ${STAGEDIR}${PREFIX}/bin/i3-msg \
- ${STAGEDIR}${PREFIX}/bin/i3-input \
- ${STAGEDIR}${PREFIX}/bin/i3-nagbar \
- ${STAGEDIR}${PREFIX}/bin/i3-dump-log
+
.include <bsd.port.mk>
diff --git a/x11-wm/i3/distinfo b/x11-wm/i3/distinfo
index aefbb82f344f..142cefb5cab8 100644
--- a/x11-wm/i3/distinfo
+++ b/x11-wm/i3/distinfo
@@ -1,2 +1,3 @@
-SHA256 (i3-4.12.tar.bz2) = e19e1ce08c2549cba83e083cc768d487202c41760d5c283f67752e791f1d78b4
-SIZE (i3-4.12.tar.bz2) = 988084
+TIMESTAMP = 1478723379
+SHA256 (i3-4.13.tar.bz2) = 94c13183e527a984132a3b050c8bf629626502a6e133e07b413641aec5f8cf8a
+SIZE (i3-4.13.tar.bz2) = 1121298
diff --git a/x11-wm/i3/files/patch-configure b/x11-wm/i3/files/patch-configure
new file mode 100644
index 000000000000..ce3980649a3c
--- /dev/null
+++ b/x11-wm/i3/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2016-11-08 18:54:08 UTC
++++ configure
+@@ -3351,7 +3351,7 @@ if test "x$_cv_gnu_make_command" = x"";
+ fi
+
+ case $srcdir in #(
+- .|.*) :
++ *) :
+
+ # pwd -P is specified in IEEE 1003.1 from 2004
+ as_dir=`cd "$srcdir" && pwd -P`
diff --git a/x11-wm/i3/files/patch-libi3_get__config__path.c b/x11-wm/i3/files/patch-libi3_get__config__path.c
new file mode 100644
index 000000000000..0dae2577dc3b
--- /dev/null
+++ b/x11-wm/i3/files/patch-libi3_get__config__path.c
@@ -0,0 +1,11 @@
+--- libi3/get_config_path.c.orig 2016-11-08 18:54:01 UTC
++++ libi3/get_config_path.c
+@@ -71,7 +71,7 @@ char *get_config_path(const char *overri
+
+ /* 4: check for $XDG_CONFIG_DIRS/i3/config */
+ if ((xdg_config_dirs = getenv("XDG_CONFIG_DIRS")) == NULL)
+- xdg_config_dirs = "/etc/xdg";
++ xdg_config_dirs = SYSCONFDIR "/xdg";
+
+ char *buf = sstrdup(xdg_config_dirs);
+ char *tok = strtok(buf, ":");