aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /x11-wm
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Makefile2
-rw-r--r--x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c11
-rw-r--r--x11-wm/emerald/Makefile1
-rw-r--r--x11-wm/metacity/Makefile13
-rw-r--r--x11-wm/metacity/distinfo6
-rw-r--r--x11-wm/metacity/files/patch-configure8
-rw-r--r--x11-wm/mutter/Makefile14
-rw-r--r--x11-wm/mutter/distinfo6
-rw-r--r--x11-wm/mutter/files/patch-src_core_main.c14
-rw-r--r--x11-wm/mutter/pkg-plist7
10 files changed, 42 insertions, 40 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index edb1daf7503d..777c2886b410 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compiz
PORTVERSION= 0.8.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
diff --git a/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c b/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c
new file mode 100644
index 000000000000..53b82dae3979
--- /dev/null
+++ b/x11-wm/compiz/files/patch-gtk_window-decorator_gtk-window-decorator.c
@@ -0,0 +1,11 @@
+--- gtk/window-decorator/gtk-window-decorator.c.orig 2010-04-06 18:29:25.000000000 +0200
++++ gtk/window-decorator/gtk-window-decorator.c 2010-04-06 18:40:04.000000000 +0200
+@@ -4233,7 +4233,7 @@ show_tooltip (const char *text)
+ static void
+ hide_tooltip (void)
+ {
+- if (GTK_WIDGET_VISIBLE (tip_window))
++ if (gtk_widget_get_visible (tip_window))
+ g_get_current_time (&tooltip_last_popdown);
+
+ gtk_widget_hide (tip_window);
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index ab14e8a77745..1ea4dcc69a12 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -37,5 +37,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
# XXX - might want to change that
post-patch:
@${REINPLACE_CMD} 's|icons/gnome|icons/hicolor|' ${WRKSRC}/misc/Makefile.in
+ @${REINPLACE_CMD} 's|#define GTK_DISABLE_DEPRECATED||g' ${WRKSRC}/include/emerald.h
.include <bsd.port.mk>
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 21a9fe87a901..7bfbde55d3e5 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -3,12 +3,11 @@
# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/metacity/Makefile,v 1.151 2009/09/22 20:27:27 kwm Exp $
+# $MCom: ports/x11-wm/metacity/Makefile,v 1.155 2010/04/06 22:47:54 marcus Exp $
#
PORTNAME= metacity
-PORTVERSION= 2.28.1
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= x11-wm
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,10 +15,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A window manager for the adult in you
-BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- canberra-gtk.0:${PORTSDIR}/audio/libcanberra
-RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+ canberra-gtk.0:${PORTSDIR}/audio/libcanberra
+RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
USE_BZIP2= yes
USE_XORG= x11 xcomposite xdamage
@@ -39,6 +38,6 @@ MAN1= metacity-message.1 metacity-theme-viewer.1 \
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
index 1c74e3e5caa5..1883d005560e 100644
--- a/x11-wm/metacity/distinfo
+++ b/x11-wm/metacity/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/metacity-2.28.1.tar.bz2) = cd444560753d63dec3ac5ee3bd061007
-SHA256 (gnome2/metacity-2.28.1.tar.bz2) = 38e4d389d6fb375e82544fd572b3a32bbcd6d26ebe58a9a0a92c461edadf95e2
-SIZE (gnome2/metacity-2.28.1.tar.bz2) = 2348762
+MD5 (gnome2/metacity-2.30.1.tar.bz2) = 3d3c05c60b70b9d06b30872e756c31ba
+SHA256 (gnome2/metacity-2.30.1.tar.bz2) = 0057b6e0562cf51b648a2d7b3729def8365ccefd12a9b1373f93312da1ebe5d8
+SIZE (gnome2/metacity-2.30.1.tar.bz2) = 2314657
diff --git a/x11-wm/metacity/files/patch-configure b/x11-wm/metacity/files/patch-configure
index e05059e0ae57..223d0af9ecf9 100644
--- a/x11-wm/metacity/files/patch-configure
+++ b/x11-wm/metacity/files/patch-configure
@@ -1,9 +1,9 @@
---- configure.orig 2009-09-22 22:18:43.000000000 +0200
-+++ configure 2009-09-22 22:19:29.000000000 +0200
-@@ -18211,7 +18211,7 @@ metacity-$VERSION:
+--- configure.orig 2010-04-01 13:44:38.000000000 +0200
++++ configure 2010-04-01 13:45:49.000000000 +0200
+@@ -24238,7 +24238,7 @@
"
- METACITY_MINOR_VERSION=28
+ METACITY_MINOR_VERSION=30
-if test $(( $(echo $METACITY_MINOR_VERSION) %2)) == "1"; then
+if test $(( $(echo $METACITY_MINOR_VERSION) %2)) = "1"; then
stable_version=$(( ($METACITY_MINOR_VERSION / 2) * 2))
diff --git a/x11-wm/mutter/Makefile b/x11-wm/mutter/Makefile
index c81afa53c5d4..5d2b9e578f25 100644
--- a/x11-wm/mutter/Makefile
+++ b/x11-wm/mutter/Makefile
@@ -3,12 +3,11 @@
# Whom: Pawel Worach <pawel.worach@gmail.com>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/mutter/Makefile,v 1.6 2009/10/07 22:59:24 kwm Exp $
+# $MCom: ports/x11-wm/mutter/Makefile,v 1.11 2010/03/28 15:56:20 kwm Exp $
#
PORTNAME= mutter
-PORTVERSION= 2.28.0
-PORTREVISION= 2
+PORTVERSION= 2.29.1
CATEGORIES= x11-wm
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,12 +15,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Window and compositing manager based on Clutter
-BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity \
- ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- clutter-glx-1.0:${PORTSDIR}/graphics/clutter
-RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity \
- ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+ clutter-glx-1.0:${PORTSDIR}/graphics/clutter \
+ canberra-gtk.0:${PORTSDIR}/audio/libcanberra
+RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
USE_BZIP2= yes
USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm
diff --git a/x11-wm/mutter/distinfo b/x11-wm/mutter/distinfo
index e668aca176f2..33ebc570861e 100644
--- a/x11-wm/mutter/distinfo
+++ b/x11-wm/mutter/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/mutter-2.28.0.tar.bz2) = 3926895782024cff7af7ca480df46b4f
-SHA256 (gnome2/mutter-2.28.0.tar.bz2) = f1917172fa4fa622dcc2aa1d82a6c4796c2981566a5c9dc1df7da2a38cd8da80
-SIZE (gnome2/mutter-2.28.0.tar.bz2) = 1986736
+MD5 (gnome2/mutter-2.29.1.tar.bz2) = ebe3c04751741fb2a028a3c6c4f1c2d7
+SHA256 (gnome2/mutter-2.29.1.tar.bz2) = 175f3adcc5ad5c6f23772ca15c862f275fc3d9a9c3104e9146cf265847a4a10a
+SIZE (gnome2/mutter-2.29.1.tar.bz2) = 1981019
diff --git a/x11-wm/mutter/files/patch-src_core_main.c b/x11-wm/mutter/files/patch-src_core_main.c
index 20b8fdb67ea9..a248e943ac3b 100644
--- a/x11-wm/mutter/files/patch-src_core_main.c
+++ b/x11-wm/mutter/files/patch-src_core_main.c
@@ -1,5 +1,5 @@
---- src/core/main.c.orig 2009-08-25 13:49:41.000000000 -0400
-+++ src/core/main.c 2009-12-19 15:03:26.000000000 -0500
+--- src/core/main.c.orig 2010-02-12 12:17:38.000000000 -0500
++++ src/core/main.c 2010-02-19 01:22:45.000000000 -0500
@@ -59,7 +59,11 @@
#include <stdlib.h>
@@ -12,13 +12,3 @@
#include <stdio.h>
#include <string.h>
#include <signal.h>
-@@ -445,6 +449,9 @@ sigterm_handler (int signum)
- }
-
- static guint sigchld_signal_id = 0;
-+#ifndef CLD_EXITED
-+#define CLD_EXITED 1
-+#endif
-
- static void
- sigchld_handler (int signum, siginfo_t *info, void *context)
diff --git a/x11-wm/mutter/pkg-plist b/x11-wm/mutter/pkg-plist
index 523a02c687ca..a768bbbe3884 100644
--- a/x11-wm/mutter/pkg-plist
+++ b/x11-wm/mutter/pkg-plist
@@ -28,8 +28,8 @@ lib/libmutter-private.a
lib/libmutter-private.la
lib/libmutter-private.so
lib/libmutter-private.so.0
-lib/mutter/Meta-2.28.gir
-lib/mutter/Meta-2.28.typelib
+lib/mutter/Meta-2.29.gir
+lib/mutter/Meta-2.29.typelib
lib/mutter/plugins/default.so
libdata/pkgconfig/libmutter-private.pc
libdata/pkgconfig/mutter-plugins.pc
@@ -92,6 +92,7 @@ share/locale/mn/LC_MESSAGES/mutter.mo
share/locale/mr/LC_MESSAGES/mutter.mo
share/locale/ms/LC_MESSAGES/mutter.mo
share/locale/nb/LC_MESSAGES/mutter.mo
+share/locale/nds/LC_MESSAGES/mutter.mo
share/locale/ne/LC_MESSAGES/mutter.mo
share/locale/nl/LC_MESSAGES/mutter.mo
share/locale/nn/LC_MESSAGES/mutter.mo
@@ -150,6 +151,8 @@ share/locale/zh_TW/LC_MESSAGES/mutter.mo
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES