aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-06 16:33:45 +0800
committermiwi <miwi@FreeBSD.org>2006-08-06 16:33:45 +0800
commit3cfe667979e405d9b1edc9c65d19c59b9df3d74d (patch)
tree2eda4117ccc30c4e65287cf17d1a65e92acd6cb5 /x11-wm
parent444c32be4d19d5c6aaaae75856e1848164c26395 (diff)
downloadfreebsd-ports-gnome-3cfe667979e405d9b1edc9c65d19c59b9df3d74d.tar.gz
freebsd-ports-gnome-3cfe667979e405d9b1edc9c65d19c59b9df3d74d.tar.zst
freebsd-ports-gnome-3cfe667979e405d9b1edc9c65d19c59b9df3d74d.zip
- Update to 2.2.7
PR: ports/101197 Submitted by: KATO Tsuguru <tkato432(at)yahoo.com> Approved by: markus (co mentor)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pawm/Makefile2
-rw-r--r--x11-wm/pawm/distinfo6
-rw-r--r--x11-wm/pawm/files/patch-src__pafont.c22
3 files changed, 24 insertions, 6 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index 42667c1d343d..00e0c107f1fd 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pawm
-PORTVERSION= 2.2.6
+PORTVERSION= 2.2.7
CATEGORIES= x11-wm
MASTER_SITES= http://www.pleyades.net/pawm/files/
diff --git a/x11-wm/pawm/distinfo b/x11-wm/pawm/distinfo
index 51f68b3a4e55..70378f9a8cc0 100644
--- a/x11-wm/pawm/distinfo
+++ b/x11-wm/pawm/distinfo
@@ -1,3 +1,3 @@
-MD5 (pawm-2.2.6.tar.bz2) = ac26398777d433e5c073157259764505
-SHA256 (pawm-2.2.6.tar.bz2) = c79ee28c95b8fe4c313e87262d84b03ccd665690d628e1d0aa3d5d3d34686640
-SIZE (pawm-2.2.6.tar.bz2) = 132854
+MD5 (pawm-2.2.7.tar.bz2) = 0fb71d60c6d691fa7987527c7b7d31d5
+SHA256 (pawm-2.2.7.tar.bz2) = 8fe92831885b17c71d041d3dee186035da2989cf2e56da03e105aefd05c7175c
+SIZE (pawm-2.2.7.tar.bz2) = 132736
diff --git a/x11-wm/pawm/files/patch-src__pafont.c b/x11-wm/pawm/files/patch-src__pafont.c
index 44004ddf016d..aafcd16e1d16 100644
--- a/x11-wm/pawm/files/patch-src__pafont.c
+++ b/x11-wm/pawm/files/patch-src__pafont.c
@@ -1,5 +1,5 @@
---- src/pafont.c.orig Thu Jun 29 20:30:15 2006
-+++ src/pafont.c Fri Jun 30 23:49:19 2006
+--- src/pafont.c.orig Tue Jul 25 05:49:39 2006
++++ src/pafont.c Fri Jul 28 16:28:48 2006
@@ -44,7 +44,7 @@
}
@@ -9,3 +9,21 @@
{
PAFont xlfdfont;
char fontname[20];
+@@ -86,7 +86,7 @@
+ {
+ ASSERT(xlfdfont);
+
+- XSetForeground(xlfdfont->display, xgc, xfldfont->color);
++ XSetForeground(xlfdfont->display, xgc, xlfdfont->color);
+ /* X and Y coordinates mark the top left corner of the text box,
+ * so we need to sum the ascent value to y to make the shitty old
+ * X font system draw the text at the right place */
+@@ -149,7 +149,7 @@
+ XColor ecolor, scolor;
+
+ XAllocNamedColor(xlfdfont->display, COLORMAP, name, &scolor, &ecolor);
+- xfldfont->color=scolor.pixel;
++ xlfdfont->color=scolor.pixel;
+ }
+
+ #else