aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-03 00:32:47 +0800
committermarino <marino@FreeBSD.org>2015-02-03 00:32:47 +0800
commit3f5ab611a40ab065d86525841b2e2d0ca8e8806f (patch)
tree95134bb340a611dec1709bca2a69f62f2c978d8d /x11-wm
parent11e61b6e1d348229d5ef9540b08d70d2ad16da7f (diff)
downloadfreebsd-ports-gnome-3f5ab611a40ab065d86525841b2e2d0ca8e8806f.tar.gz
freebsd-ports-gnome-3f5ab611a40ab065d86525841b2e2d0ca8e8806f.tar.zst
freebsd-ports-gnome-3f5ab611a40ab065d86525841b2e2d0ca8e8806f.zip
x11-wm/swm: This is not jobs-safe
The port tries to build the swm executable before the swm.o object file is finished building. While marking this jobs-unsafe, pet portlint so it doesn't complain. It doesn't like "file" being used as a variable name.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/swm/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-wm/swm/Makefile b/x11-wm/swm/Makefile
index 5982a4601a46..087fdad8411d 100644
--- a/x11-wm/swm/Makefile
+++ b/x11-wm/swm/Makefile
@@ -34,6 +34,8 @@ SCRIPTS= startswm
DATA= background.xpm closebox.xpm maxbox.xpm stickybox.xpm \
swm.colors unstickybox.xpm
+MAKE_JOBS_UNSAFE= yes
+
post-patch:
@${REINPLACE_CMD} -e 's|monotype|fixed|g ; \
s|/usr/share/swm|${DATADIR}|g' ${WRKSRC}/swm.conf
@@ -45,11 +47,11 @@ post-build:
*.c -o ${WRKSRC}/swmswitch -lX11 -L${LOCALBASE}/lib
do-install:
-.for file in ${BINS}
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+.for f in ${BINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
-.for file in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+.for f in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/swm.1x ${STAGEDIR}${MANPREFIX}/man/man1/swm.1
${INSTALL_MAN} ${WRKSRC}/../swmbg/swmbg.1x ${STAGEDIR}${MANPREFIX}/man/man1/swmbg.1