aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-26 22:41:43 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-26 22:41:43 +0800
commit77b2028b6bf0138d17a7cf00579a6e9e8e955395 (patch)
treee32b638603110ab434242eb6014ff9b4fe648b53 /x11-wm
parentc6799b3d86a3b08ae816222d137ddc5b3aa77f76 (diff)
downloadfreebsd-ports-gnome-77b2028b6bf0138d17a7cf00579a6e9e8e955395.tar.gz
freebsd-ports-gnome-77b2028b6bf0138d17a7cf00579a6e9e8e955395.tar.zst
freebsd-ports-gnome-77b2028b6bf0138d17a7cf00579a6e9e8e955395.zip
- Respect CXXFLAGS
- Unbreak and undeprecate (chase libsigc++20 update)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/gcompmgr/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11-wm/gcompmgr/Makefile b/x11-wm/gcompmgr/Makefile
index c3cc0271497d..4779394284f8 100644
--- a/x11-wm/gcompmgr/Makefile
+++ b/x11-wm/gcompmgr/Makefile
@@ -12,13 +12,10 @@ COMMENT= GNOME interface to xcompmgr
RUN_DEPENDS= xcompmgr:x11-wm/xcompmgr
-BROKEN= fails to compile: ustring.h: expected ';' at end of declaration list
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2018-01-27
-
GNU_CONFIGURE= yes
LIBS+= -L${LOCALBASE}/lib -lX11
-USES= autoreconf libtool pkgconfig
+USES= compiler:c++11-lang autoreconf libtool pkgconfig
+USE_CXXSTD= c++11
USE_GNOME= gtkmm24
USE_XORG= x11
@@ -33,6 +30,7 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${RM} ${WRKSRC}/INSTALL
+ @${REINPLACE_CMD} -e '/^CXXFLAGS=""/d' ${WRKSRC}/configure.in
@${REINPLACE_CMD} -e 's|connect(SigC::slot|connect(sigc::mem_fun|g ; \
s|#include <sigc++\/compatibility\.h>||g' \
${WRKSRC}/src/*.cc