aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-20 01:00:05 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-20 01:00:05 +0800
commit98164eb9188604c5a44933e7a8708a3daf011f31 (patch)
tree17b107dd2407d515da09e3ddab3a28aefa5959e8 /x11-wm
parent4b17e8fb5c3b5e5ea0506988029966481f4131c2 (diff)
downloadfreebsd-ports-gnome-98164eb9188604c5a44933e7a8708a3daf011f31.tar.gz
freebsd-ports-gnome-98164eb9188604c5a44933e7a8708a3daf011f31.tar.zst
freebsd-ports-gnome-98164eb9188604c5a44933e7a8708a3daf011f31.zip
- Change Makefile header
- Bump PORTREVISION - Pass maintainership to submitter - Add license (GPLv2) - Support STAGEDIR - Add Desktop entry file and pkg-message PR: ports/175944 Submitted by: nemysis (self) Approved by: pawel (mentor)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/obmenu/Makefile24
-rw-r--r--x11-wm/obmenu/files/pkg-message.in19
-rw-r--r--x11-wm/obmenu/pkg-plist3
3 files changed, 36 insertions, 10 deletions
diff --git a/x11-wm/obmenu/Makefile b/x11-wm/obmenu/Makefile
index ffb5ff96b85a..169dd45dab29 100644
--- a/x11-wm/obmenu/Makefile
+++ b/x11-wm/obmenu/Makefile
@@ -1,14 +1,17 @@
+# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
PORTNAME= obmenu
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-wm
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Menu manager for Openbox supporting both static and pipe menus
+LICENSE= GPLv2
+
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -16,13 +19,18 @@ PYDISTUTILS_PKGNAME= obMenu
PORTDOCS= README
-NO_STAGE= yes
+SUB_FILES= pkg-message
+
+DESKTOP_ENTRIES="Obmenu" "Menu manager for Openbox" ${PORTNAME} \
+ "${PORTNAME}" "Settings;" false
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
+ ${LN} -sf ${DATADIR}/mnu48.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/x11-wm/obmenu/files/pkg-message.in b/x11-wm/obmenu/files/pkg-message.in
new file mode 100644
index 000000000000..a5ce8692cb9a
--- /dev/null
+++ b/x11-wm/obmenu/files/pkg-message.in
@@ -0,0 +1,19 @@
+===============================================================================
+
+Obmenu has been installed.
+
+If you don't have ~/.config/openbox/menu.xml
+
+the Obmenu config can be copied, please type as user:
+
+ su user
+
+ cp %%LOCALBASE%%/etc/xdg/openbox/menu.xml ~/.config/openbox/menu.xml
+
+ chmod 644 ~/.config/openbox/menu.xml
+
+ exit
+
+Have fun!
+
+===============================================================================
diff --git a/x11-wm/obmenu/pkg-plist b/x11-wm/obmenu/pkg-plist
index 5ed1805b68ce..661c22b19b55 100644
--- a/x11-wm/obmenu/pkg-plist
+++ b/x11-wm/obmenu/pkg-plist
@@ -9,6 +9,5 @@ bin/obmenu
%%DATADIR%%/mnu16.png
%%DATADIR%%/mnu48.png
%%DATADIR%%/obmenu.glade
+share/pixmaps/obmenu.png
@dirrm %%DATADIR%%
-@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%