aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11-wm
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/Makefile4
-rw-r--r--x11-wm/fvwm/Makefile3
-rw-r--r--x11-wm/olvwm/Makefile8
-rw-r--r--x11-wm/piewm/Makefile4
-rw-r--r--x11-wm/treewm/Makefile2
5 files changed, 8 insertions, 13 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index e3bd29abbcb5..500973349b09 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= asclock:${PORTSDIR}/x11-clocks/asclock
NO_LATEST_LINK= yes
USE_XORG= xpm xext x11
-USE_IMAKE= yes
+USES= imake
INSTALL_TARGET= install install.man
MANCOMPRESSED= yes
MAN1= afterstep.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
@@ -42,7 +42,7 @@ post-patch:
done
pre-build:
- @ cd ${WRKSRC}; ${SH} MakeMakefiles
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles
post-install:
@ ${MKDIR} ${PREFIX}/lib/X11/afterstep/backgrounds/
diff --git a/x11-wm/fvwm/Makefile b/x11-wm/fvwm/Makefile
index 5121a98bffdb..9b1001b2b0c7 100644
--- a/x11-wm/fvwm/Makefile
+++ b/x11-wm/fvwm/Makefile
@@ -13,10 +13,9 @@ COMMENT= The fvwm window manager
NO_LATEST_LINK= yes
MAKE_JOBS_UNSAFE= yes
-USE_IMAKE= yes
+USES= imake
USE_XORG= xbitmaps xpm xext x11 xmu
# must overwrite the default from bsd.port.mk
-XMKMF= xmkmf
ALL_TARGET= Makefiles all
MAN1= FvwmAudio.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmClean.1 \
FvwmDebug.1 FvwmIconBox.1 FvwmIdent.1 FvwmPager.1 FvwmSave.1 \
diff --git a/x11-wm/olvwm/Makefile b/x11-wm/olvwm/Makefile
index 0ec7bfb090c1..c72a3f7d87c9 100644
--- a/x11-wm/olvwm/Makefile
+++ b/x11-wm/olvwm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: olvwm
-# Date created: 21 October 1994
-# Whom: smace
-#
+# Created by: smace
# $FreeBSD$
-#
PORTNAME= olvwm
PORTVERSION= 4.2
@@ -31,7 +27,7 @@ LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
REINPLACE_ARGS= -i ""
NO_WRKSUBDIR= yes
-USE_IMAKE= yes
+USES= imake
USE_XORG= xpm
MAN1= olvwm.1 olvwmrc.1
XFREE86_HTML_MAN= no
diff --git a/x11-wm/piewm/Makefile b/x11-wm/piewm/Makefile
index 3ab02919a469..df2ed0d6a475 100644
--- a/x11-wm/piewm/Makefile
+++ b/x11-wm/piewm/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= x11-wm
MASTER_SITES= http://www.crynwr.com/piewm/
MAINTAINER= david@catwhisker.org
-COMMENT= A tvtwm with pie (circular) menus
+COMMENT= tvtwm with pie (circular) menus
+USES= imake
DISABLE_SIZE= yes
-USE_IMAKE= yes
USE_XORG= xbitmaps xpm xmu
MAN1= piewm.1
diff --git a/x11-wm/treewm/Makefile b/x11-wm/treewm/Makefile
index 03421e4c1780..073f8ae2f708 100644
--- a/x11-wm/treewm/Makefile
+++ b/x11-wm/treewm/Makefile
@@ -12,7 +12,7 @@ COMMENT= Window manager that arranges windows in a tree
LICENSE= GPLv2
-BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake
+USES= imake:env
USE_BZIP2= yes
USE_GMAKE= yes