aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2017-10-05 04:14:24 +0800
committerzeising <zeising@FreeBSD.org>2017-10-05 04:14:24 +0800
commitec155bc778b991bfc3ab3466f34b40d2d5d423aa (patch)
treee868d804982d9a2b406e639ca84c52362e76925a /x11-wm
parent753d7c72d7d766a3f24c26d25fa1f1e18ef011cf (diff)
downloadfreebsd-ports-gnome-ec155bc778b991bfc3ab3466f34b40d2d5d423aa.tar.gz
freebsd-ports-gnome-ec155bc778b991bfc3ab3466f34b40d2d5d423aa.tar.zst
freebsd-ports-gnome-ec155bc778b991bfc3ab3466f34b40d2d5d423aa.zip
Update to 3.1.0
Changelog: Add +R for region index to bar formatting. Add new bar_color_selected and bar_font_color_selected options. Add new 'ws_empty' action. Enable padding in the bar_format using '_' character Handle MappingNotify during startup. Reset SIGPIPE before execvp(). Correct size for WM_STATE This release also fixes a bunch of bugs, linux build and man page nits. FreeBSD specific changes: Thhe screenshot.sh script is now installed into the examples dir, instead of bin/. If you are using it, you need to update your configuration file. I've reworked the examples handling and hid all examoles behind the EXAMPLES knob (on by default). This is mostly some example configurations, but I also added the baraction.sh script which can be used to do fancier stuff with the status bar.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/spectrwm/Makefile25
-rw-r--r--x11-wm/spectrwm/distinfo6
-rw-r--r--x11-wm/spectrwm/files/patch-spectrwm.c4
-rw-r--r--x11-wm/spectrwm/pkg-plist9
4 files changed, 31 insertions, 13 deletions
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index 7367a9b80237..25208cb97f3c 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spectrwm
DISTVERSIONPREFIX= SPECTRWM_
-DISTVERSION= 3_0_2
+DISTVERSION= 3_1_0
CATEGORIES= x11-wm
MAINTAINER= zeising@FreeBSD.org
@@ -19,38 +19,49 @@ RUN_DEPENDS+= dmenu:x11/dmenu
USE_GITHUB= yes
GH_ACCOUNT= conformal
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
+
USE_XORG= x11 xcb xcursor xft xrandr xt
USE_LDCONFIG= yes
-PORTEXAMPLES= spectrwm_cz.conf \
+CONFEXAMPLES= spectrwm_cz.conf \
spectrwm_es.conf \
spectrwm_fr.conf \
spectrwm_fr_ch.conf \
spectrwm_se.conf \
spectrwm_us.conf
+SCRIPTEXAMPLES= baraction.sh \
+ screenshot.sh
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/spectrwm.*
do-build:
- ${CC} ${CFLAGS} -I${LOCALBASE}/include \
+ ${CC} ${CFLAGS} -Wall -Werror -I${LOCALBASE}/include \
-I${LOCALBASE}/include/freetype2 -I${WRKSRC}/freebsd \
-lutil -L${LOCALBASE}/lib -lX11 -lX11-xcb -lxcb -lxcb-icccm \
-lxcb-keysyms -lxcb-randr -lxcb-util -lxcb-xtest -lXcursor \
-lXft -DSWM_LIB=\"${PREFIX}/lib/libswmhack.so\" \
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
- ${CC} ${CFLAGS} -I${LOCALBASE}/include -shared -fpic -DPIC \
+ ${CC} ${CFLAGS} -Wall -Werror -I${LOCALBASE}/include -shared -fpic -DPIC \
-o ${WRKSRC}/libswmhack.so ${WRKSRC}/lib/swm_hack.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/screenshot.sh ${STAGEDIR}${PREFIX}/bin
${INSTALL_LIB} ${WRKSRC}/libswmhack.so ${STAGEDIR}${PREFIX}/lib
${INSTALL_MAN} ${WRKSRC}/spectrwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/spectrwm.conf ${STAGEDIR}${PREFIX}/etc/spectrwm.conf.sample
+
+do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.for conf in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${conf} ${STAGEDIR}${EXAMPLESDIR}
+.for file in ${CONFEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
+.for file in ${SCRIPTEXAMPLES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.include <bsd.port.mk>
diff --git a/x11-wm/spectrwm/distinfo b/x11-wm/spectrwm/distinfo
index 70ed115b9cf4..548b8d71ee68 100644
--- a/x11-wm/spectrwm/distinfo
+++ b/x11-wm/spectrwm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465236118
-SHA256 (conformal-spectrwm-SPECTRWM_3_0_2_GH0.tar.gz) = 82ce0280039de642c41684f3096abb0388926b60c37987ca1dbc53a0913cab18
-SIZE (conformal-spectrwm-SPECTRWM_3_0_2_GH0.tar.gz) = 147355
+TIMESTAMP = 1507141425
+SHA256 (conformal-spectrwm-SPECTRWM_3_1_0_GH0.tar.gz) = b7a5e24fe6d923aadab947d354ff44ad742b721daaf334584e8eea9e15649d9a
+SIZE (conformal-spectrwm-SPECTRWM_3_1_0_GH0.tar.gz) = 147206
diff --git a/x11-wm/spectrwm/files/patch-spectrwm.c b/x11-wm/spectrwm/files/patch-spectrwm.c
index 5640a7b57450..746ff32216c2 100644
--- a/x11-wm/spectrwm/files/patch-spectrwm.c
+++ b/x11-wm/spectrwm/files/patch-spectrwm.c
@@ -1,6 +1,6 @@
---- spectrwm.c.orig 2016-06-05 07:12:06 UTC
+--- spectrwm.c.orig 2017-10-04 18:36:20 UTC
+++ spectrwm.c
-@@ -7876,7 +7876,7 @@ validate_spawns(void)
+@@ -7960,7 +7960,7 @@ validate_spawns(void)
void
setup_spawn(void)
{
diff --git a/x11-wm/spectrwm/pkg-plist b/x11-wm/spectrwm/pkg-plist
index 11cf843f8b17..794235a11450 100644
--- a/x11-wm/spectrwm/pkg-plist
+++ b/x11-wm/spectrwm/pkg-plist
@@ -1,5 +1,12 @@
bin/spectrwm
-bin/screenshot.sh
lib/libswmhack.so
man/man1/spectrwm.1.gz
@sample etc/spectrwm.conf.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/baraction.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/screenshot.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_cz.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_es.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_fr.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_fr_ch.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_se.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrwm_us.conf