aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-03-23 08:34:28 +0800
committerdanilo <danilo@FreeBSD.org>2014-03-23 08:34:28 +0800
commit292b139b5bb366ea5821c20fcae567561d1df18f (patch)
tree73142bafd0ede697008f99270814520692ce074a /x11-wm
parent833574f10dcd97f8ef7461c661ca1ca032348ac2 (diff)
downloadfreebsd-ports-gnome-292b139b5bb366ea5821c20fcae567561d1df18f.tar.gz
freebsd-ports-gnome-292b139b5bb366ea5821c20fcae567561d1df18f.tar.zst
freebsd-ports-gnome-292b139b5bb366ea5821c20fcae567561d1df18f.zip
- Add the port: x11-wm/cwm
- Pass maintainership to submitter cwm is a window manager for X11 initially inspired by evilwm. cwm has several novel features, including the ability to search for windows. it features a very simple and attractive aesthetic. PR: ports/187803 Submitted by: <braakvaak@aol.com>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/cwm/Makefile28
-rw-r--r--x11-wm/cwm/distinfo2
-rw-r--r--x11-wm/cwm/files/patch-Makefile25
-rw-r--r--x11-wm/cwm/pkg-descr8
5 files changed, 64 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 6421c08a3b6c..4ecb157e1f61 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -26,6 +26,7 @@
SUBDIR += compizconfig-python
SUBDIR += compton
SUBDIR += ctwm
+ SUBDIR += cwm
SUBDIR += devilspie
SUBDIR += dwm
SUBDIR += e16
diff --git a/x11-wm/cwm/Makefile b/x11-wm/cwm/Makefile
new file mode 100644
index 000000000000..232cd2d3c415
--- /dev/null
+++ b/x11-wm/cwm/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= cwm
+PORTVERSION= 5.5
+CATEGORIES= x11-wm
+MASTER_SITES= http://chneukirchen.org/releases/ \
+ http://github.com/chneukirchen/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= braakvaak@aol.com
+COMMENT= Minimalistic window manager for X11 based on evilwm
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+
+USES= pkgconfig:build
+USE_XORG= x11 xft xinerama xrandr
+
+PLIST_FILES= bin/cwm \
+ man/man1/cwm.1.gz \
+ man/man5/cwmrc.5.gz
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cwm ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/cwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/cwmrc.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/x11-wm/cwm/distinfo b/x11-wm/cwm/distinfo
new file mode 100644
index 000000000000..71fc74d2c78d
--- /dev/null
+++ b/x11-wm/cwm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cwm-5.5.tar.gz) = 99aa337f15b07e36ba3b03593c56f65b76f8bbef6f73daca73846f6b002f2187
+SIZE (cwm-5.5.tar.gz) = 50709
diff --git a/x11-wm/cwm/files/patch-Makefile b/x11-wm/cwm/files/patch-Makefile
new file mode 100644
index 000000000000..2c4ad0d98807
--- /dev/null
+++ b/x11-wm/cwm/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- ./Makefile.orig 2014-03-17 03:52:56.000000000 +0100
++++ ./Makefile 2014-03-17 04:05:08.000000000 +0100
+@@ -3,7 +3,7 @@
+
+ PROG= cwm
+
+-PREFIX= /usr/local
++#PREFIX= /usr/local
+
+ SRCS= calmwm.c screen.c xmalloc.c client.c menu.c \
+ search.c util.c xutil.c conf.c xevents.c group.c \
+@@ -16,11 +16,11 @@
+
+ CPPFLAGS+= `pkg-config --cflags fontconfig x11 xft xinerama xrandr`
+
+-CFLAGS= -Wall -O2 -g -D_GNU_SOURCE
++CFLAGS+= -Wall -g -pthread
+
+ LDFLAGS+= `pkg-config --libs fontconfig x11 xft xinerama xrandr`
+
+-MANPREFIX= ${PREFIX}/share/man
++#MANPREFIX= ${PREFIX}/share/man
+
+ all: ${PROG}
+
diff --git a/x11-wm/cwm/pkg-descr b/x11-wm/cwm/pkg-descr
new file mode 100644
index 000000000000..fd37326f9742
--- /dev/null
+++ b/x11-wm/cwm/pkg-descr
@@ -0,0 +1,8 @@
+cwm is a window manager for X11 initially inspired by evilwm. cwm has several
+novel features, including the ability to search for windows. it features a
+very simple and attractive aesthetic.
+
+This port is based on OpenBSD's continued work on cwm, as development on the
+project seems to have halted.
+
+WWW: http://monkey.org/~marius/pages/?page=cwm