aboutsummaryrefslogtreecommitdiffstats
path: root/x11/3ddesktop/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-12 16:33:18 +0800
committeradamw <adamw@FreeBSD.org>2003-06-12 16:33:18 +0800
commitc8f0ca14566db3c1657ba9f4873e07f2705d7505 (patch)
treef5c76437596cb43573890912d9dfc49de79cab98 /x11/3ddesktop/Makefile
parent6d069a5251f85effc720be1c68c16c29c006225f (diff)
downloadfreebsd-ports-gnome-c8f0ca14566db3c1657ba9f4873e07f2705d7505.tar.gz
freebsd-ports-gnome-c8f0ca14566db3c1657ba9f4873e07f2705d7505.tar.zst
freebsd-ports-gnome-c8f0ca14566db3c1657ba9f4873e07f2705d7505.zip
Add 3ddesktop, a 3D Virtual Desktop Switcher.
Throws up all your virtual desktops into one giant rotating OpenGL carousel. It works with many different WindowManagers, and is very configurable.
Diffstat (limited to 'x11/3ddesktop/Makefile')
-rw-r--r--x11/3ddesktop/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11/3ddesktop/Makefile b/x11/3ddesktop/Makefile
new file mode 100644
index 000000000000..1dfb30e6dd06
--- /dev/null
+++ b/x11/3ddesktop/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: 3ddesktop
+# Date created: 12 June 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 3ddesktop
+PORTVERSION= 0.2.5
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= desk3d
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= 3D Virtual Desktop Switcher
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README README.windowmanagers
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>