aboutsummaryrefslogtreecommitdiffstats
path: root/x11/9box
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /x11/9box
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'x11/9box')
-rw-r--r--x11/9box/Makefile8
-rw-r--r--x11/9box/files/patch-src::Makefile4
2 files changed, 5 insertions, 7 deletions
diff --git a/x11/9box/Makefile b/x11/9box/Makefile
index 6e97349b015b..7374d81e40b2 100644
--- a/x11/9box/Makefile
+++ b/x11/9box/Makefile
@@ -7,7 +7,7 @@
PORTNAME= 9box
PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
@@ -16,15 +16,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= 9box can "pack" windows inside itself
PLIST_FILES= bin/9box
-USE_XLIB= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_XORG= xbitmaps
+USE_XORG= xbitmaps x11 xt
BUILD_WRKSRC= ${WRKSRC}/src
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g; \
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%CC%%|${CC}|g' \
${WRKSRC}/src/Makefile
diff --git a/x11/9box/files/patch-src::Makefile b/x11/9box/files/patch-src::Makefile
index 68e2c34d4905..654ee9c50f60 100644
--- a/x11/9box/files/patch-src::Makefile
+++ b/x11/9box/files/patch-src::Makefile
@@ -2,8 +2,8 @@
+++ src/Makefile Wed Jul 23 21:35:39 2003
@@ -1,10 +1,14 @@
+CC= %%CC%%
-+CFLAGS+= -g -I. -I%%X11BASE%%/include
-+LIBS+= -L%%X11BASE%%/lib -lX11
++CFLAGS+= -g -I. -I%%LOCALBASE%%/include
++LIBS+= -L%%LOCALBASE%%/lib -lX11
+
all: 9box