aboutsummaryrefslogtreecommitdiffstats
path: root/x11/XFree86-4-clients/Makefile
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2002-10-17 15:20:03 +0800
committeranholt <anholt@FreeBSD.org>2002-10-17 15:20:03 +0800
commit3dae6bbb516fec9bfcdf48ddf7751b4bc567c22a (patch)
tree0acfbf3a6277cbde9ebd74ce059793b8b936e7b8 /x11/XFree86-4-clients/Makefile
parent3f799016a652135e258dffb274eb127ea19e6b9c (diff)
downloadfreebsd-ports-gnome-3dae6bbb516fec9bfcdf48ddf7751b4bc567c22a.tar.gz
freebsd-ports-gnome-3dae6bbb516fec9bfcdf48ddf7751b4bc567c22a.tar.zst
freebsd-ports-gnome-3dae6bbb516fec9bfcdf48ddf7751b4bc567c22a.zip
[1] Make the 4.2.1 ports all use the merged 4.2.1+mitshm patch.
[2] Make the ports respect CFLAGS better. Now CFLAGS (and CC/CXX) are set for the build during the configure stage. PR: [2] 40271, 43369
Diffstat (limited to 'x11/XFree86-4-clients/Makefile')
-rw-r--r--x11/XFree86-4-clients/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index b77dd5d00a35..622f3f5ecf56 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -7,20 +7,17 @@
PORTNAME= clients
PORTVERSION= 4.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
- ${MASTER_SITE_XFREE:S/source//g:S/$/:x421patch/}
-MASTER_SITE_SUBDIR= 4.2.0/:x \
- ${PORTVERSION}/patches/:x421patch \
- anholt/:local
+MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/}
+MASTER_SITE_SUBDIR= 4.2.0/:x
PKGNAMEPREFIX= XFree86-
-DISTFILES= X420src-1.tgz:x \
- X420src-2.tgz:x \
- 4.2.0-4.2.1.diff.gz:x421patch
+DISTFILES= X420src-1.tgz:x
EXTRACT_ONLY= X420src-1.tgz
-PATCH_DIST_STRIP= -p1
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= anholt/patches-4.2.0/
+PATCHFILES= 4.2.0-4.2.1-1-freebsd.patch.gz
MAINTAINER= anholt@freebsd.org
@@ -36,7 +33,10 @@ SCRIPTS_ENV= InstallXdmConfig=${InstallXdmConfig} \
InstallXinitConfig=${InstallXinitConfig} \
InstallAppDefFiles=${InstallAppDefFiles} \
HasSecureRPC=${HasSecureRPC} \
- HasPam=${HasPam}
+ HasPam=${HasPam} \
+ CC="${CC}" \
+ CXX="${CXX}" \
+ CFLAGS="${CFLAGS}"
MAKE_ENV= PKGNAMEPREFIX=${PKGNAMEPREFIX} \
PORTNAME=${PORTNAME} \
PORTVERSION=${PORTVERSION}
@@ -67,9 +67,6 @@ post-extract:
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${DIST_SUBDIR}/X420src-2.tgz \
| ${TAR} -xf - xc/fonts/util )
-pre-patch:
- -@${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/4.2.0-4.2.1.diff.gz \
- | ${PATCH} ${PATCH_DIST_ARGS} --batch
post-patch:
cd ${WRKSRC}/nls; \