aboutsummaryrefslogtreecommitdiffstats
path: root/x11/XFree86-4-libraries/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1995-01-05 11:51:15 +0800
committerjmz <jmz@FreeBSD.org>1995-01-05 11:51:15 +0800
commitab1ba4f530807ee595c20af511bf586553501366 (patch)
tree10eee1ce197066a69ef08e7c3e87a8a02c806356 /x11/XFree86-4-libraries/Makefile
parentf5fa37dccd928cc3712af570e73580f4f71a6cb4 (diff)
downloadfreebsd-ports-gnome-ab1ba4f530807ee595c20af511bf586553501366.tar.gz
freebsd-ports-gnome-ab1ba4f530807ee595c20af511bf586553501366.tar.zst
freebsd-ports-gnome-ab1ba4f530807ee595c20af511bf586553501366.zip
This is X11R6/XFree86 3.1
The actual makefile does nothing! You have to edit it and remove a comment to build the beast. Note: there are in fact 2 makefiles: one which fetches the files from ftp.x.org and another which allows to compile from a cdrom. Note2: I have not extensively tested the port! (only one build!)
Diffstat (limited to 'x11/XFree86-4-libraries/Makefile')
-rw-r--r--x11/XFree86-4-libraries/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
new file mode 100644
index 000000000000..c8cbd163b4bb
--- /dev/null
+++ b/x11/XFree86-4-libraries/Makefile
@@ -0,0 +1,46 @@
+DISTNAME = xc
+PKGNAME = XFree86-3.1
+
+# uncomment one of the 2 lines below!
+#X11_ON_CDROM = yes
+#X11_VIA_FTP = yes
+
+#define this if you are short of space - save ~28 Mbytes
+#REMOVE_NOT_ESSENTIAL = yes
+
+
+.if defined(X11_ON_CDROM) || defined(X11_VIA_FTP)
+build:
+.if defined(REMOVE_NOT_ESSENTIAL)
+ @rm -rf ${WRKSRC}/test ${WRKSRC}/doc/hardcopy ${WRKSRC}/doc/specs
+ @find ${WRKSRC}/ -name '*.orig' -exec rm -f {} ';'
+.endif
+ @(cd ${WRKSRC}; echo Good night...; make World)
+ @touch ${WRKDIR}/.build_done
+
+install:
+ @(cd ${WRKSRC}; make install; make install.man)
+ @touch ${WRKDIR}/.install_done
+.endif
+
+
+.if defined(X11_ON_CDROM)
+.include "Makefile.cdrom"
+.elif defined(X11_VIA_FTP)
+.include "Makefile.ftp"
+.else
+all:
+ @echo -n
+fetch:
+ @echo -n
+extract:
+ @echo -n
+configure:
+ @echo -n
+build:
+ @echo -n
+install:
+ @echo -n
+.endif
+
+