aboutsummaryrefslogtreecommitdiffstats
path: root/x11/XFree86-4-libraries/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1995-02-17 09:23:44 +0800
committerjmz <jmz@FreeBSD.org>1995-02-17 09:23:44 +0800
commitcfdaeeaabd25cbfa15d8afa1ab8186b6aced299c (patch)
treec66bdd79f9b0b02b287c469a4cc06f9bf96a47ba /x11/XFree86-4-libraries/Makefile
parent2d37faf16c8d8c3865a41223145cd25cd76804e0 (diff)
downloadfreebsd-ports-gnome-cfdaeeaabd25cbfa15d8afa1ab8186b6aced299c.tar.gz
freebsd-ports-gnome-cfdaeeaabd25cbfa15d8afa1ab8186b6aced299c.tar.zst
freebsd-ports-gnome-cfdaeeaabd25cbfa15d8afa1ab8186b6aced299c.zip
Makefiles have been simplified, and most of the work is now done in
configure. In particular patches are now done by the script. The port is now interactive, (ask for servers to be build, if you want to build fonts, etc) This time I have build it (successfully) from a cdrom.
Diffstat (limited to 'x11/XFree86-4-libraries/Makefile')
-rw-r--r--x11/XFree86-4-libraries/Makefile38
1 files changed, 29 insertions, 9 deletions
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 8dd186298ab1..ebda54445823 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -1,23 +1,28 @@
-DISTNAME = xc
-PKGNAME = XFree86-3.1.1
-WRKDIR?= ${.CURDIR}/work
-BUILD_COOKIE?= ${WRKDIR}/.build_done
-PATCH_STRIP = -p1
-
# uncomment one of the 2 lines below!
#X11_ON_CDROM = yes
X11_VIA_FTP = yes
+#if you are compiling from a cdrom, set the directory where the
+# the patch files are
+#X11FIXES = /home/X11R6
+
#define this if you are short of space - save ~28 Mbytes
#REMOVE_NOT_ESSENTIAL = yes
+#######################################################################
+DISTNAME = xc
+PKGNAME = XFree86-3.1.1
+WRKDIR?= ${.CURDIR}/work
+BUILD_COOKIE?= ${WRKDIR}/.build_done
+EXTRACT_COOKIE?= ${WRKDIR}/.extract_done
+IS_INTERACTIVE= yes
.if defined(X11_ON_CDROM) || defined(X11_VIA_FTP)
+
build: configure ${BUILD_COOKIE}
${BUILD_COOKIE}:
@echo "===> Building for ${DISTNAME}"
- @${MAKE} ${.MAKEFLAGS} pre-build
.if defined(REMOVE_NOT_ESSENTIAL)
@rm -rf ${WRKSRC}/test ${WRKSRC}/doc/hardcopy ${WRKSRC}/doc/specs
@find ${WRKSRC}/ -name '*.orig' -exec rm -f {} ';'
@@ -28,10 +33,25 @@ ${BUILD_COOKIE}:
install:
@(cd ${WRKSRC}; make install; make install.man)
@touch ${WRKDIR}/.install_done
+.if defined(X11_ON_CDROM)
+ @find /usr/X11R6/ -name 00_TRANS.TBL -exec rm -f {} ';'
+.endif
.endif
.if defined(X11_ON_CDROM)
-.include "Makefile.cdrom"
+.if !defined (X11FIXES)
+configure:
+ @echo Edit the makefile and set X11FIXES !!!!
+ @exit 1;
+.endif
+fetch:
+ @echo -n
+${EXTRACT_COOKIE}:
+ @rm -rf ${WRKDIR}
+ @mkdir -p ${WRKDIR}
+ @echo ${X11FIXES} > ${WRKDIR}/.cdrom
+ @${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
+
.elif defined(X11_VIA_FTP)
.include "Makefile.ftp"
.else
@@ -49,4 +69,4 @@ install:
@echo -n
.endif
-
+.include <bsd.port.mk>