aboutsummaryrefslogtreecommitdiffstats
path: root/x11/antimicro/Makefile
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-31 01:45:32 +0800
commit9e393f4b3db656d0acb466d9fa3f9888cb501ddc (patch)
treeeee5b882c5b82c2ca4dc978b8c472738369c1655 /x11/antimicro/Makefile
parentd17a363e6665033194d363b3fe95be83bb36c24e (diff)
downloadfreebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.gz
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.tar.zst
freebsd-ports-gnome-9e393f4b3db656d0acb466d9fa3f9888cb501ddc.zip
Finish fixing broken ports after r404856 and r404694.
* multimedia/obs-studio: Import some upstream commits that pass all required include directories to the compiler and reference libsysinfo.so with a full path instead of passing -lsysinfo and relying on ${LOCALBASE}/lib being in the linker search path. * textproc/sigil: Pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that upstream's build system references libhunspell-1.3.so and libpcre16.so without full paths (instead of finding them with the proper CMake commands it relies on pkg-config's output). * x11/antimicro: Also pass LDFLAGS+=${LOCALBASE}/lib for now to work around the fact that several X11 and SDL2 libraries are referenced without full paths. I sent a pull request upstream to fix the X11 references, but SDL2 is still detected through pkg-config. MFH: 2015Q4
Diffstat (limited to 'x11/antimicro/Makefile')
-rw-r--r--x11/antimicro/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11/antimicro/Makefile b/x11/antimicro/Makefile
index c697ca266edf..43c791368e29 100644
--- a/x11/antimicro/Makefile
+++ b/x11/antimicro/Makefile
@@ -13,6 +13,11 @@ LICENSE= GPLv3
USE_GITHUB= yes
GH_ACCOUNT= Ryochan7
+# Upstream assumes ${LOCALBASE}/lib is part of the default linker path. Pull
+# request 268 fixes it for X11 libraries, but SDL2 is still using pkg-config
+# output (without full paths).
+LDFLAGS+= ${LOCALBASE}/lib
+
USE_XORG= x11 xtst
USE_QT5= linguisttools_build qmake_build buildtools_build widgets network
USE_SDL= sdl2