aboutsummaryrefslogtreecommitdiffstats
path: root/x11/blast
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-12-29 22:06:03 +0800
committerantoine <antoine@FreeBSD.org>2013-12-29 22:06:03 +0800
commit237484a515f184009d05a639644304e8a79a547f (patch)
treeb2fc5ff84965c6d50582c627358a21b6fd39c3ac /x11/blast
parent947baf24c21feb21c37459724c00f800167d7915 (diff)
downloadfreebsd-ports-gnome-237484a515f184009d05a639644304e8a79a547f.tar.gz
freebsd-ports-gnome-237484a515f184009d05a639644304e8a79a547f.tar.zst
freebsd-ports-gnome-237484a515f184009d05a639644304e8a79a547f.zip
Stage support
Diffstat (limited to 'x11/blast')
-rw-r--r--x11/blast/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/x11/blast/Makefile b/x11/blast/Makefile
index 8ff40004a51a..abfd12fac2ae 100644
--- a/x11/blast/Makefile
+++ b/x11/blast/Makefile
@@ -14,15 +14,13 @@ COMMENT= Blast blows holes through windows
WRKSRC= ${WRKDIR}/${PORTNAME}-1.1.orig
USE_XORG= ice sm x11 xau xcursor xdmcp xext xfixes xt xrandr
-MAN1= blast.1
-PLIST_FILES= bin/blast
+PLIST_FILES= bin/blast man/man1/blast.1.gz
-NO_STAGE= yes
do-build:
${CC} ${CFLAGS} ${WRKSRC}/blast.c -I${LOCALBASE}/include -L${LOCALBASE}/lib -lX11 -lXext -o ${WRKSRC}/blast
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/blast ${PREFIX}/bin/blast
- ${INSTALL_MAN} ${WRKSRC}/blast.man ${MANPREFIX}/man/man1/blast.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/blast ${STAGEDIR}${PREFIX}/bin/blast
+ ${INSTALL_MAN} ${WRKSRC}/blast.man ${STAGEDIR}${MANPREFIX}/man/man1/blast.1
.include <bsd.port.mk>