aboutsummaryrefslogtreecommitdiffstats
path: root/x11/bricons/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-04 22:24:08 +0800
committermiwi <miwi@FreeBSD.org>2013-02-04 22:24:08 +0800
commita6880322bd19421a1d03a4e7378fd1acfd49194f (patch)
treefbdaf0bec8b63603c9ead65b286e32ff24e86572 /x11/bricons/Makefile
parenteebe32ad4f3c61f9dd6d54a6ee9a53cc3c657d8a (diff)
downloadfreebsd-ports-gnome-a6880322bd19421a1d03a4e7378fd1acfd49194f.tar.gz
freebsd-ports-gnome-a6880322bd19421a1d03a4e7378fd1acfd49194f.tar.zst
freebsd-ports-gnome-a6880322bd19421a1d03a4e7378fd1acfd49194f.zip
- Update MASTER_SITES
- Fix build with clang - Add MAKE_JOBS_SAFE PR: 175587 Submitted by: Ports Fury
Diffstat (limited to 'x11/bricons/Makefile')
-rw-r--r--x11/bricons/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/x11/bricons/Makefile b/x11/bricons/Makefile
index f430fbe72262..6799c3cbbe64 100644
--- a/x11/bricons/Makefile
+++ b/x11/bricons/Makefile
@@ -7,24 +7,31 @@
PORTNAME= bricons
PORTVERSION= 3.0
+DISTVERSIONPREFIX= athena-
PORTREVISION= 2
CATEGORIES= x11
-MASTER_SITES= ftp://ftp.x.org/R5contrib/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= -athena-3.0.tar.Z
+MASTER_SITES= XCONTRIB/../R5contrib
+EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Quick start up utility for applications on an X display
-USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
USE_PERL5_BUILD=yes
USE_XORG= xaw
+USE_IMAKE= yes
+MAKE_JOBS_SAFE= yes
+
MAN1= bricons.1
.include <bsd.port.pre.mk>
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Xbricons
+ @${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/Xbricons
+ @${REINPLACE_CMD} -e \
+ 's|^unsigned int argc|int argc|' ${WRKSRC}/main.c
post-install:
${INSTALL_DATA} ${WRKSRC}/Xbricons ${PREFIX}/lib/X11/app-defaults