aboutsummaryrefslogtreecommitdiffstats
path: root/x11/bricons/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1996-11-25 18:00:33 +0800
committertg <tg@FreeBSD.org>1996-11-25 18:00:33 +0800
commitf1b468623d0025fceef3dad300b796da5c81959e (patch)
tree9cda029c683c71d1c2aef3dcf764eafb1bc0f806 /x11/bricons/Makefile
parentf430fbb45cfe086089f68dbda1f51bd67fd61590 (diff)
downloadfreebsd-ports-gnome-f1b468623d0025fceef3dad300b796da5c81959e.tar.gz
freebsd-ports-gnome-f1b468623d0025fceef3dad300b796da5c81959e.tar.zst
freebsd-ports-gnome-f1b468623d0025fceef3dad300b796da5c81959e.zip
Import of bricons, a start up utility for applications on an X display.
Closes PR 1529. Submitted by: Andreas Kohout <shanee@rabbit.augusta.de>
Diffstat (limited to 'x11/bricons/Makefile')
-rw-r--r--x11/bricons/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/bricons/Makefile b/x11/bricons/Makefile
new file mode 100644
index 000000000000..9ce5c33da652
--- /dev/null
+++ b/x11/bricons/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bricons
+# Version required: 3.0 with colour icons
+# Date created: 31 Jul 1996
+# Whom: shanee@rabbit.augusta.de
+#
+# $Id$
+#
+
+DISTNAME= bricons
+PKGNAME= bricons-3.0
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.uni-paderborn.de/unix/X11/ftp.x.org/R5contrib/ \
+ ftp://ftp.pasteur.fr/pub/computing/unix/X11/R5contrib/
+EXTRACT_SUFX= -athena-3.0.tar.gz
+
+MAINTAINER= shanee@rabbit.augusta.de
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+
+post-install:
+ ${INSTALL_DATA} $(WRKDIR)/bricons/Xbricons $(PREFIX)/lib/X11/app-defaults/
+ ${INSTALL_DATA} $(WRKDIR)/bricons/bitmaps/* $(PREFIX)/include/X11/bitmaps/
+ ${INSTALL_DATA} $(WRKDIR)/bricons/*.xpm $(PREFIX)/include/X11/pixmaps/
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Use ./files/DOTbriconsrc as an example. This file"
+ @${ECHO_MSG} " should be stored in the same directory as the"
+ @${ECHO_MSG} " program is executed from."
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>