aboutsummaryrefslogtreecommitdiffstats
path: root/x11/cnslock/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-04-10 22:29:39 +0800
committerfjoe <fjoe@FreeBSD.org>2003-04-10 22:29:39 +0800
commit33454b7b0081892f150d06bd2cb4723210eaf180 (patch)
tree12cec1a56ee20d03ad4a791d6b46f9d229d61efc /x11/cnslock/Makefile
parent07985f12b2aa4e5ed8e2d82b8df6c084ffafaf4c (diff)
downloadfreebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.tar.gz
freebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.tar.zst
freebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.zip
New port: cnslock
Cnslock is a dock application (dockapp) which provides a visual indication of the states of the three "lock" buttons (caps, num, and scroll). It should be especially useful for people who own a wireless keyboard with no leds on it, and thus have difficulty keeping track of "lock" states. Submitted by: Alexey Dokuchaev
Diffstat (limited to 'x11/cnslock/Makefile')
-rw-r--r--x11/cnslock/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/cnslock/Makefile b/x11/cnslock/Makefile
new file mode 100644
index 000000000000..39b48e6cbf5e
--- /dev/null
+++ b/x11/cnslock/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cnslock
+# Date created: 10 May 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cnslock
+PORTVERSION= 1.02
+CATEGORIES= x11 windowmaker
+MASTER_SITES= http://www.dockapps.com/download.php/id/181/ \
+ ftp://ftp.nsu.ru/tmp/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= A visual indicator of the states of the three "lock" buttons
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>