aboutsummaryrefslogtreecommitdiffstats
path: root/x11/deskmenu/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-03-16 17:22:30 +0800
committerdanfe <danfe@FreeBSD.org>2016-03-16 17:22:30 +0800
commiteea1ef8e9a0f29cce90329c065cbd00a315c3a6a (patch)
treeeb19247fe41434769af00386bd632e8a196d5762 /x11/deskmenu/Makefile
parent806be4ec60954bc75fcc2ef7271f503ff2825209 (diff)
downloadfreebsd-ports-gnome-eea1ef8e9a0f29cce90329c065cbd00a315c3a6a.tar.gz
freebsd-ports-gnome-eea1ef8e9a0f29cce90329c065cbd00a315c3a6a.tar.zst
freebsd-ports-gnome-eea1ef8e9a0f29cce90329c065cbd00a315c3a6a.zip
- Update to version 1.4.5, which is based on GTK+ 2.x now
- Unbreak fetching: upstream are using Debian CDN officially - Stop demanding GNU make: builds fine with BSD make as well - Define LICENSE (GPLv2), install couple of docs and sample configuration file while here - Update port description text and project web address
Diffstat (limited to 'x11/deskmenu/Makefile')
-rw-r--r--x11/deskmenu/Makefile40
1 files changed, 29 insertions, 11 deletions
diff --git a/x11/deskmenu/Makefile b/x11/deskmenu/Makefile
index 4153920cd66a..f84d22e4d4f7 100644
--- a/x11/deskmenu/Makefile
+++ b/x11/deskmenu/Makefile
@@ -2,21 +2,39 @@
# $FreeBSD$
PORTNAME= deskmenu
-PORTVERSION= 1.3.0
-PORTREVISION= 5
+PORTVERSION= 1.4.5
CATEGORIES= x11
-MASTER_SITES= http://matt.peterson.org/FreeBSD/ports/ \
- http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/
+MASTER_SITES= DEBIAN/pool/main/d/${PORTNAME} GENTOO
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= matt@peterson.org
COMMENT= X11 application launcher
-BROKEN= Does not fetch
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-04-15
-PLIST_FILES= bin/deskmenu
-USES= gmake
-USE_GNOME= gtk12
-USE_CSTD= gnu89
+LICENSE= GPLv2
+
+USES= pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/deskmenu man/man1/deskmenu.1.gz \
+ @sample\ etc/deskmenurc.sample
+PORTDOCS= AUTHORS ChangeLog
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O2 -g ,,' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,/etc/deskmenurc,${ETCDIR}rc,' \
+ ${WRKSRC}/example_rc ${WRKSRC}/src/deskmenu.c
+ @${LN} -sf debian/changelog ${WRKSRC}/ChangeLog
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/example_rc ${STAGEDIR}${ETCDIR}rc.sample
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>