aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dgs/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 09:28:49 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 09:28:49 +0800
commitd98115cf1760f114b4c9f2a0017a41c910ceb68d (patch)
tree964e70c65a895f7ddc1121fce62e4d0cb2e6201c /x11/dgs/Makefile
parentdcc922b45d4234c97f2d12b006e52074226f4c9c (diff)
downloadfreebsd-ports-gnome-d98115cf1760f114b4c9f2a0017a41c910ceb68d.tar.gz
freebsd-ports-gnome-d98115cf1760f114b4c9f2a0017a41c910ceb68d.tar.zst
freebsd-ports-gnome-d98115cf1760f114b4c9f2a0017a41c910ceb68d.zip
[PATCH] x11/dgs: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54956 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'x11/dgs/Makefile')
-rw-r--r--x11/dgs/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index 246c03fc69e0..eabaa5fb0654 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -14,10 +14,16 @@ MASTER_SITE_SUBDIR= dgs
MAINTAINER= nakai@FreeBSD.org
COMMENT= A display ghostscript system
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -32,6 +38,14 @@ MANN= dpsexec.man makepsres.man xepsf.man
.error You have `USE_DGS' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|manm|mann|g'