aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dgs
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /x11/dgs
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'x11/dgs')
-rw-r--r--x11/dgs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index f56b5663d370..81f596cf55f4 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dgs
PORTVERSION= 0.5.9.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ../old-gnu/dgs
@@ -20,7 +20,7 @@ MAKE_JOBS_UNSAFE= yes
USE_GHOSTSCRIPT_RUN= yes
USE_XORG= xt sm ice xext x11
USE_GNOME= glib12
-USES= gmake libtool
+USES= gmake libtool:keepla
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-0.5.9